Bug 240932 - editors/libreoffice: 6.3.3.2 thumbnails do not display
Summary: editors/libreoffice: 6.3.3.2 thumbnails do not display
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-office mailing list
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2019-09-30 08:07 UTC by John Murphy
Modified: 2019-11-05 15:07 UTC (History)
7 users (show)

See Also:
koobs: maintainer-feedback? (office)
johnjomurphy+bugz: maintainer-feedback?
johnjomurphy+bugz: maintainer-feedback?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Murphy 2019-09-30 08:07:36 UTC
LibreOffice from PKG does not display thumbnails when first opened. 
Strangely, it displays old thumbnails, but if that document has been opened and closed - the thumbnail becomes a blank black box. 
Related: it does not show icons for Textmath - just blank black boxes
This is seen on a Plasma5 desktop
Comment 1 peo 2019-10-01 17:18:27 UTC
I can confirm this, think it started with 6.3.0 and is still there
Same on 11-STABLE and 12-STABLE

OPTIONS_FILE_SET+=CUPS
OPTIONS_FILE_SET+=DOCS
OPTIONS_FILE_UNSET+=GNOME
OPTIONS_FILE_SET+=GTK2
OPTIONS_FILE_UNSET+=GTK3
OPTIONS_FILE_SET+=JAVA
OPTIONS_FILE_SET+=KDE5
OPTIONS_FILE_SET+=MMEDIA
OPTIONS_FILE_UNSET+=PGSQL
OPTIONS_FILE_SET+=QT5
OPTIONS_FILE_UNSET+=SDK
OPTIONS_FILE_UNSET+=SYSTRAY
OPTIONS_FILE_SET+=TEST
OPTIONS_FILE_SET+=WEBDAV
Comment 2 John Murphy 2019-10-02 03:13:38 UTC
Just noticed that the "Print Preview" pane is similarly just a black square. 
Document printed OK, but again no preview.
Comment 3 John Murphy 2019-10-02 03:29:34 UTC
Apologies Correction: the Preview print screen is OK, it is the automatic preview generated when "Print" is chosen. IE just before going to actually print.
Comment 4 Dwayne MacKinnon 2019-10-29 18:52:35 UTC
Just want to report that I'm seeing the exact same thing: No preview thumbnails in dolphin for kde5/plasma5 and no document preview for the "Print" screen. Just black boxes. I'm running FreeBSD 12.0-RELEASE-p10 and LibreOffice 6.3.2.2 from ports.
Comment 5 John Murphy 2019-11-03 08:09:42 UTC
This may have an effect wider than Libreoffice.
It seems that any png files written in the last few months cannot be rendered - but SVG and others (wmf) can be. 
Made me change my workflow for images in LO - but I hope this helps others.
Comment 6 John Murphy 2019-11-05 02:52:11 UTC
This bug seems to have disappeared with an upgrade to 
LibreOffice 6.3.3.2.0 30(Build:2) today.

However, I hesitate to say it's fixed because the upgrade to LO came as a result of installing krita 4.2.7.1. That install upgraded a number of other programs such as Inkscape, poppler etc - so the fix may have been in one of the associated libraries. I don't have the expertise to find out for sure - so I'll leave it to those more expert.

Anyway, good to see it's fixed; didn't realise how much I depended on previews.
Comment 7 Li-Wen Hsu freebsd_committer 2019-11-05 06:53:56 UTC
(In reply to John Murphy from comment #6)
Thanks for the update, can more people to help confirm this is fixed and we can close this PR?
Comment 8 peo 2019-11-05 14:27:35 UTC
Finished an upgrade of the port just now, I can confirm it works.

Per
Comment 9 Li-Wen Hsu freebsd_committer 2019-11-05 15:07:10 UTC
Close as it has received reports from 2 people state it works.

BTW, I think the subject should be "6.3.2" because "6.3.3" was not released when this ticket filed and 6.3.3 is the version that reported no problem.