Bug 240941 - /bin/sh: bind|less results in segmentation fault
Summary: /bin/sh: bind|less results in segmentation fault
Status: Closed DUPLICATE of bug 233343
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 12.0-RELEASE
Hardware: Any Any
: --- Affects Many People
Assignee: Jilles Tjoelker
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-30 14:25 UTC by corvid
Modified: 2019-10-05 14:10 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description corvid 2019-09-30 14:25:51 UTC
As in summary.

$ lldb -c sh.core /bin/sh
(lldb) bt
* thread #1, name = 'sh', stop reason = signal SIGSEGV
  * frame #0: 0x000000080028f170 libedit.so.7`___lldb_unnamed_symbol33$$libedit.so.7 + 128
    frame #1: 0x0000000800295381 libedit.so.7`el_wparse + 401
    frame #2: 0x000000080029506b libedit.so.7`el_parse + 59
    frame #3: 0x000000000020ed4e sh`___lldb_unnamed_symbol38$$sh + 3486
    frame #4: 0x000000000020d7eb sh`___lldb_unnamed_symbol35$$sh + 555
    frame #5: 0x000000000020d911 sh`___lldb_unnamed_symbol35$$sh + 849
    frame #6: 0x0000000000219988 sh`___lldb_unnamed_symbol134$$sh + 232
    frame #7: 0x000000000021980a sh`___lldb_unnamed_symbol132$$sh + 602
    frame #8: 0x000000000020b11b sh`___lldb_unnamed_symbol1$$sh + 283
Comment 1 andrew 2019-09-30 14:33:29 UTC
Appears to be a duplicate of #233343 (already closed)
Comment 2 Jilles Tjoelker freebsd_committer 2019-10-05 14:10:00 UTC

*** This bug has been marked as a duplicate of bug 233343 ***