Bug 240978 - regression Import DTS files from Linux 5.2/5.3
Summary: regression Import DTS files from Linux 5.2/5.3
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: arm (show other bugs)
Version: CURRENT
Hardware: arm64 Any
: --- Affects Only Me
Assignee: freebsd-arm mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-01 19:03 UTC by Manuel Stühn
Modified: 2019-11-28 17:52 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Stühn 2019-10-01 19:03:47 UTC
With import of Linux 5.2 DTS files (r352935), this change (https://github.com/torvalds/linux/commit/0a3df8bb6dad730d8d368f0dc4c3d7888bd5b789) deleted the  lines 'phy-names = "usb";' from USB entries. That actually disables the usb function on Allwinner NanoPI NEO2 on FreeBSD.

I was able to restore the USB-functionality locally by adding this lines via overlay.
Comment 1 commit-hook freebsd_committer 2019-10-01 20:23:09 UTC
A commit references this bug:

Author: manu
Date: Tue Oct  1 20:22:54 UTC 2019
New revision: 352941
URL: https://svnweb.freebsd.org/changeset/base/352941

Log:
  arm: allwinner: a10_ehci:  Look for the phy based on the id

  phy-names was never in the bindings schema even if it was present
  in some DTS. Get the optional phy based on its ID.

  PR:		240978

Changes:
  head/sys/arm/allwinner/a10_ehci.c
Comment 2 Emmanuel Vadot freebsd_committer 2019-10-01 20:23:35 UTC
Sorry for the breakage, this is now fixed.
Comment 3 commit-hook freebsd_committer 2019-11-28 17:52:46 UTC
A commit references this bug:

Author: manu
Date: Thu Nov 28 17:52:27 UTC 2019
New revision: 355178
URL: https://svnweb.freebsd.org/changeset/base/355178

Log:
  MFC r352940-r352941, r352943-r352944, r353062-r353063, r353125

  r352940:
  generic_ohci: Look for the phy based on the id

  phy-names was never in the bindings schema even if it was present
  in some DTS. Get the optional phy based on its ID.

  r352941:
  arm: allwinner: a10_ehci:  Look for the phy based on the id

  phy-names was never in the bindings schema even if it was present
  in some DTS. Get the optional phy based on its ID.

  PR:		240978

  r352943:
  arm: allwinner: a10_ehci: Enable all phys

  Even if there should be only one phy enable all the ones declared in
  the dts just to be sure.

  r352944:
  generic_ehci: Enable all phys and resets

  The number of phys and resets is not defined and it controller dependent
  so enable/disable every one of them.

  r353062:
  Split out the attachment from the generic-ehci driver

  Create an attachment file for the existing ACPI attachment, and create a
  new FDT attachment for the generic-ehci driver.

  Submitted by:	andrew (Original version)
  Differential Revision:	https://reviews.freebsd.org/D19389

  r353063:
  allwinner: Remove a10_ehci driver

  We have generic-ehci since r353062 so use it.

  X-MFC-With:	r353062

  r353125:
  arm64: rockchip: usb2phy: Add set/get mode

  We only support host mode so those functions are just added so
  we won't panic when generic-{e,o}hci will set the phy to host mode.

  X-MFC-With:	r353062

Changes:
_U  stable/12/
  stable/12/sys/arm/allwinner/a10_ehci.c
  stable/12/sys/arm/allwinner/files.allwinner
  stable/12/sys/arm64/conf/GENERIC
  stable/12/sys/arm64/rockchip/rk_usb2phy.c
  stable/12/sys/conf/files.arm64
  stable/12/sys/dev/usb/controller/generic_ehci.c
  stable/12/sys/dev/usb/controller/generic_ehci.h
  stable/12/sys/dev/usb/controller/generic_ehci_acpi.c
  stable/12/sys/dev/usb/controller/generic_ehci_fdt.c
  stable/12/sys/dev/usb/controller/generic_ohci.c