Bug 241001 - audio/xanalyser: Remove libXp dependency
Summary: audio/xanalyser: Remove libXp dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: hamradio
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-02 09:08 UTC by Niclas Zeising
Modified: 2019-10-06 00:27 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (hamradio)


Attachments
v1 (1.18 KB, patch)
2019-10-02 09:08 UTC, Niclas Zeising
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Niclas Zeising freebsd_committer 2019-10-02 09:08:24 UTC
Created attachment 208012 [details]
v1

libXp is being deprecated.  Attached patch removes the dependency on it from audio/xanalyser.
Comment 1 commit-hook freebsd_committer 2019-10-06 00:22:46 UTC
A commit references this bug:

Author: db
Date: Sun Oct  6 00:22:34 UTC 2019
New revision: 513859
URL: https://svnweb.freebsd.org/changeset/ports/513859

Log:
  libXp is being deprecated.

  Also fixed Makefile to properly patch xanalyser.spec.in
  Replaced hard coded /usr/local in favour of PREFIX and LOCALBASE as needed

  PR:		ports/241001

Changes:
  head/audio/xanalyser/Makefile
  head/audio/xanalyser/files/patch-src_Makefile.in
  head/audio/xanalyser/files/patch-xanalyser.spec.in