Bug 241032 - mail/fetchmail: allow manpage rendering without groff
Summary: mail/fetchmail: allow manpage rendering without groff
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Matthias Andree
URL: https://gitlab.com/fetchmail/fetchmai...
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-03 09:37 UTC by Helge Oldach
Modified: 2019-10-10 00:22 UTC (History)
3 users (show)

See Also:
chalpin: maintainer-feedback+


Attachments
Patch (416 bytes, patch)
2019-10-03 09:37 UTC, Helge Oldach
no flags Details | Diff
Proposed patch (416 bytes, patch)
2019-10-09 13:04 UTC, Corey Halpin
chalpin: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Helge Oldach 2019-10-03 09:37:10 UTC
Created attachment 208049 [details]
Patch

Without textproc/groff installed, the fetchmail manpage cannot be rendered (on 12.0 and above). The root cause is a line break in a table that serves purely cosmetic purposes. Attached trivial patch will remove it.
Comment 1 Corey Halpin 2019-10-09 13:04:14 UTC
Created attachment 208199 [details]
Proposed patch

Looks good to me and works in my testing.

Attached is a revised version suitable for placing in the 'files' directory.
Comment 2 Matthias Andree freebsd_committer 2019-10-09 17:15:41 UTC
Committed. I'll keep this open until I've merged it upstream.
Comment 3 commit-hook freebsd_committer 2019-10-09 17:15:49 UTC
A commit references this bug:

Author: mandree
Date: Wed Oct  9 17:15:30 UTC 2019
New revision: 514172
URL: https://svnweb.freebsd.org/changeset/ports/514172

Log:
  fetchmail: Fix manpage rendering w/ groff, fix t.smoke failure

  PR:		240914
  PR:		241032
  Submitted by:	Corey Halpin (maintainer)
  Reported by:	Helge Oldach, Konstantin Belousov

Changes:
  head/mail/fetchmail/Makefile
  head/mail/fetchmail/files/patch-fetchmail.man
  head/mail/fetchmail/files/patch-t.smoke
Comment 4 commit-hook freebsd_committer 2019-10-09 17:19:53 UTC
A commit references this bug:

Author: mandree
Date: Wed Oct  9 17:19:43 UTC 2019
New revision: 514173
URL: https://svnweb.freebsd.org/changeset/ports/514173

Log:
  MFH: r514172

  fetchmail: Fix manpage rendering w/ groff, fix t.smoke failure

  PR:		240914
  PR:		241032
  Submitted by:	Corey Halpin (maintainer)
  Reported by:	Helge Oldach, Konstantin Belousov

  One patch removes a .br from the .man page to fix manpage rendering
  with groff on FreeBSD 12.0, one patch changes the environment for a
  build-time self-test that will not be installed but unbreaks a build
  in some configurations, hence claiming blanket approval.

  Approved by:	ports-secteam@ (blanket)

Changes:
_U  branches/2019Q4/
  branches/2019Q4/mail/fetchmail/Makefile
  branches/2019Q4/mail/fetchmail/files/patch-fetchmail.man
  branches/2019Q4/mail/fetchmail/files/patch-t.smoke