Bug 241057 - net-im/py-matrix-synapse: Update to 1.4.0
Summary: net-im/py-matrix-synapse: Update to 1.4.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Thomas Zander
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2019-10-04 13:15 UTC by Sascha Biberhofer
Modified: 2019-10-06 14:29 UTC (History)
2 users (show)

See Also:


Attachments
net-im/py-matrix-synapse: 1.2.1 to 1.4.0 diff (1.56 KB, patch)
2019-10-04 13:15 UTC, Sascha Biberhofer
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sascha Biberhofer 2019-10-04 13:15:21 UTC
Created attachment 208091 [details]
net-im/py-matrix-synapse: 1.2.1 to 1.4.0 diff

This is a simple bump for py-matrix-synapse from 1.2.1 to 1.4.0. I've updated the dependencies in accordance with the upstream dep list and bumped the version. The package has been running fine on my homeserver for the last few days, so I don't expect any problems.

I've also been thinking of making the dependency on postgres the default in the future. The synapse maintainers strongly recommend postgres for basically anything but a very limited test or lab setup. I'm happy for suggestions in this regard. :)

Cheers,
Sascha
Comment 1 commit-hook freebsd_committer 2019-10-06 11:18:34 UTC
A commit references this bug:

Author: riggs
Date: Sun Oct  6 11:17:51 UTC 2019
New revision: 513882
URL: https://svnweb.freebsd.org/changeset/ports/513882

Log:
  Update to upstream version 1.4.0

  PR:		241057
  Submitted by:	ports@skyforge.at (maintainer)

Changes:
  head/net-im/py-matrix-synapse/Makefile
  head/net-im/py-matrix-synapse/distinfo
Comment 2 Thomas Zander freebsd_committer 2019-10-06 11:25:17 UTC
There are no security issues mentioned in the changelog, thus you do not plan to request MFH, correct?
Comment 3 Sascha Biberhofer 2019-10-06 14:29:25 UTC
(In reply to Thomas Zander from comment #2)

I'm a bit uncertain about this. There are always bugfixes present in each release, but as far as I'm aware there were no security relevant fixed between 1.2.1 and 1.4.0.

The 1.4.0 realease is however particularly noteworthy as it changes the way things like email addresses/password resets can be handled. This *shouldn't* (even according to upstream) directly affect 1.2.1 users in the immediate future, so I think MFH isn't strictly necessary, but I'd leave the final decision to you.