Bug 241081 - databases/xtrabackup: Update to 2.4.15
Summary: databases/xtrabackup: Update to 2.4.15
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steve Wills
URL:
Keywords: needs-qa
: 241082 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-10-05 12:44 UTC by Oleksii Samorukov
Modified: 2019-10-07 14:57 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (aleks)


Attachments
Update to 2.4.15 (7.60 KB, patch)
2019-10-05 12:44 UTC, Oleksii Samorukov
koobs: maintainer-approval? (aleks)
Details | Diff
Poudriere logs for 11.3-RELEASE-p3 FreeBSD 11.3-RELEASE-p3 amd64 (56.61 KB, application/x-bzip2)
2019-10-05 13:02 UTC, Oleksii Samorukov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleksii Samorukov freebsd_committer 2019-10-05 12:44:15 UTC
Created attachment 208114 [details]
Update to 2.4.15

- Update to 2.4.15
- Remove obsoleted patches
- Disable version functionality using CMAKE_ARGS instead of patches
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-10-05 12:46:45 UTC
*** Bug 241082 has been marked as a duplicate of this bug. ***
Comment 2 Oleksii Samorukov freebsd_committer 2019-10-05 13:02:32 UTC
Created attachment 208117 [details]
Poudriere logs for 11.3-RELEASE-p3 FreeBSD 11.3-RELEASE-p3 amd64
Comment 3 Aleksandr Kuzminsky 2019-10-05 14:53:38 UTC
approved
Comment 4 Oleksii Samorukov freebsd_committer 2019-10-05 18:56:06 UTC
As discussed with Aleksandr Kuzminsky - please change maintainer to samm@os2.kiev.ua. 

PS - Aleksandr, please approve
Comment 5 Aleksandr Kuzminsky 2019-10-05 19:31:15 UTC
Approved - please make samm@os2.kiev.ua the maintainer of xtrabackup.
Comment 6 commit-hook freebsd_committer 2019-10-07 14:57:36 UTC
A commit references this bug:

Author: swills
Date: Mon Oct  7 14:56:34 UTC 2019
New revision: 513955
URL: https://svnweb.freebsd.org/changeset/ports/513955

Log:
  databases/xtrabackup: Update to 2.4.15

  While here, pass maintainership to submitter

  PR:		241081
  Submitted by:	samm@os2.kiev.ua
  Approved by:	Aleksandr Kuzminsky <aleks@twindb.com> (maintainer)

Changes:
  head/databases/xtrabackup/Makefile
  head/databases/xtrabackup/distinfo
  head/databases/xtrabackup/files/patch-cmake-install_layout.cmake
  head/databases/xtrabackup/files/patch-plugin_keyring_common_system__keys__container.cc
  head/databases/xtrabackup/files/patch-storage_innobase_row_row0sel.cc
  head/databases/xtrabackup/files/patch-storage_innobase_xtrabackup_src_CMakeLists.txt
  head/databases/xtrabackup/files/patch-storage_innobase_xtrabackup_src_backup__copy.cc
  head/databases/xtrabackup/files/patch-storage_innobase_xtrabackup_src_xtrabackup.cc
Comment 7 Steve Wills freebsd_committer 2019-10-07 14:57:38 UTC
Committed, thanks!