Bug 241104 - textproc/rubygem-sassc package problem
Summary: textproc/rubygem-sassc package problem
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-06 17:29 UTC by Maksim E. Kozlov
Modified: 2019-10-06 18:45 UTC (History)
3 users (show)

See Also:
w.schwarzenfeld: maintainer-feedback? (sunpoet)


Attachments
original error output (438.85 KB, text/plain)
2019-10-06 17:29 UTC, Maksim E. Kozlov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maksim E. Kozlov 2019-10-06 17:29:22 UTC
Created attachment 208143 [details]
original error output

Hi,

I think that something wrong with creating package of rubygem-sassc port. Originally I run into troubles with GitLab (unicorn, to be exact) which ceased to launch after update (I use packages). Unicorn's log says (full outout of this error in the attachment):

/usr/local/lib/ruby/gems/2.6/gems/ffi-1.11.1/lib/ffi/library.rb:112: [BUG] Illegal instruction at 0x000000080c9890ff
ruby 2.6.5p114 (2019-10-01 revision 67812) [amd64-freebsd12]

After some investigation and googling I found out that error happens on trying to open libsass.so library (by dlopen call, as I understand) and did some experiments.

At firts, I checked it with dltest:

# dltest /usr/local/lib/ruby/gems/2.6/gems/sassc-2.2.1/lib/sassc/libsass.so
Illegal instruction (core dumped)

Then I reinstalled rubygem-sassc from port and check it again:

# dltest /usr/local/lib/ruby/gems/2.6/gems/sassc-2.2.1/lib/sassc/libsass.so
SUCCESS: Loaded /usr/local/lib/ruby/gems/2.6/gems/sassc-2.2.1/lib/sassc/libsass.so

GitLab launched correctly and work without errors after this.

After that I saved "good" libsass.so, reinstalled rubygem-sassc as package again and tryed to launch GitLab - without success. Then I replaced original libsass.so by previously saved and tryed to launch GitLab again - it launched an worked correctly.

My system:

# uname -a
FreeBSD felix 12.0-RELEASE-p10 FreeBSD 12.0-RELEASE-p10 r353051 MYKERNEL  amd64

# cat /usr/local/etc/pkg/repos/FreeBSD.conf 
FreeBSD: {
  url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest"
}
Comment 1 Steve Wills freebsd_committer 2019-10-06 18:11:20 UTC
This is fixed in PR 241063
Comment 2 Maksim E. Kozlov 2019-10-06 18:45:23 UTC
(In reply to Steve Wills from comment #1)

Hi Steve,

I saw mentioned bug report, but you say there that it "builds but is not usable".  I my case it builds and is usable if I do that on my host. And the problem appears only when I install package from official repository. Are you sure that this is the same problem? I saw the patch, but I'm absolutly far from ruby and can't make an opinion about that.