Bug 241153 - freebsd-update tells users to upgrade to a release that doesn't exist
Summary: freebsd-update tells users to upgrade to a release that doesn't exist
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 12.0-RELEASE
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-09 12:01 UTC by Paul Lettington
Modified: 2019-10-09 12:01 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Lettington 2019-10-09 12:01:46 UTC
On a fresh install of 12.0-RELEASE, freebsd-update upgrade gave me the following message:

WARNING: FreeBSD 12.0-RELEASE is approaching its End-of-Life date.
It is strongly recommended that you upgrade to a newer
release within the next 2 months.

However, there is no newer release for me to move to. 12.1 is still in the beta stage and isn't due for release for another month.

freebsd-upgrade should check for the existence of a newer release before printing the warning about end of life.