Bug 241173 - devel/py-virtualenv: Broken with python27
Summary: devel/py-virtualenv: Broken with python27
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Nicola Vitale
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-10 07:38 UTC by Dani
Modified: 2019-10-20 21:09 UTC (History)
2 users (show)

See Also:
antoine: maintainer-feedback-


Attachments
Fix py-virtualenv build for python27 (584 bytes, patch)
2019-10-10 07:39 UTC, Dani
i.dani: maintainer-approval? (antoine)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dani 2019-10-10 07:38:32 UTC
py-virtualenv doesn't build for python27 if py27-pathlib2 hasn't been built befor - due to a broken dependency.

===>   py27-virtualenv-16.7.5 depends on package: py27-pathlib2>0 - not found
===>   py27-virtualenv-16.7.5 depends on package: /packages/All/py27-pathlib2-2.3.4.txz - not found
===>   USE_PACKAGE_DEPENDS_ONLY set - not building missing dependency from source
*** Error code 1

The fix in ports r512469 isn't correct according to: https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/flavors-using.html

The attached fix fixes this.
Comment 1 Dani 2019-10-10 07:39:42 UTC
Created attachment 208222 [details]
Fix py-virtualenv build for python27

Add patch to fix py-virtualenv build for python27
Comment 2 Antoine Brodin freebsd_committer 2019-10-20 21:06:46 UTC
The proposed patch is wrong.
Comment 3 Antoine Brodin freebsd_committer 2019-10-20 21:09:22 UTC
This may be a problem due to the tool you are using.