Bug 241248 - gdb is no longer the debugger that comes with FreeBSD
Summary: gdb is no longer the debugger that comes with FreeBSD
Status: Closed FIXED
Alias: None
Product: Documentation
Classification: Unclassified
Component: Documentation (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-doc (Nobody)
URL: https://www.freebsd.org/doc/en_US.ISO...
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-14 21:22 UTC by PauAmma
Modified: 2020-06-15 10:47 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback? (emaste)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description PauAmma freebsd_triage 2019-10-14 21:22:08 UTC
Yet, that chapter still features gdb (and only gdb) throughout. I think it should be rewritten to feature lldb instead (or perhaps both). I can't suggest language at this time, though, because I need to learn the basics of lldb first.
Comment 1 PauAmma freebsd_triage 2019-11-01 00:19:20 UTC
Are there architectures and/or supported versions where gdb is still the default FreeBSD debugger? I'm unsure whether lldb should be added to it, or replace it altogether.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-30 01:57:19 UTC
Ed might have some insight into what can/ought to be done that could inform doc changes
Comment 3 PauAmma freebsd_triage 2020-04-04 16:47:28 UTC
Based on an IRC discussion with kevans91 and debdrup, I'll add lldb and leave gdb in since I'm told it's still the recommended tool (adding a mention to get it from ports/pkg if not available in base), unless someone tells me otherwise before I get a round tuit.
Comment 4 PauAmma freebsd_triage 2020-06-15 10:43:31 UTC
Can this be closed following https://svnweb.freebsd.org/doc?view=revision&revision=54255 ?
Comment 5 Benedict Reuschling freebsd_committer 2020-06-15 10:47:47 UTC
Yes, I was not aware that this PR existed. With the changes committed to the developers handbook, the issue is resolved. Thanks again for working on the text!