Bug 241314 - [exp-run] update x11/xorgproto to 2019.2
Summary: [exp-run] update x11/xorgproto to 2019.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Niclas Zeising
URL:
Keywords:
: 242024 (view as bug list)
Depends on:
Blocks: 240801
  Show dependency treegraph
 
Reported: 2019-10-17 17:24 UTC by Niclas Zeising
Modified: 2019-11-17 13:00 UTC (History)
4 users (show)

See Also:
zeising: maintainer-feedback+
zeising: exp-run?


Attachments
v1 (8.53 KB, patch)
2019-10-17 17:24 UTC, Niclas Zeising
no flags Details | Diff
v2 (10.33 KB, patch)
2019-10-23 07:41 UTC, Niclas Zeising
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Niclas Zeising freebsd_committer 2019-10-17 17:24:20 UTC
Created attachment 208389 [details]
v1

Hi!
I'd like to request an exp-run for updating x11/xorgproto to 2019.2.  The update touches a fair amount of ports, and there has been some substantial changes in which headers are shipped.
The attached patch updates x11/xorgproto to 2019.2, and also updates x11/libXcMC and lib/X11 to new versions, which are required in order for those ports to build with the updated xorgproto.

I am aware of two failures with this update, x11/libXp and x11/libXxf86misc.  Both of those are deprecated and will be removed before I commit this.

Thank you!
Comment 3 commit-hook freebsd_committer 2019-10-23 07:11:53 UTC
A commit references this bug:

Author: zeising
Date: Wed Oct 23 07:10:58 UTC 2019
New revision: 515236
URL: https://svnweb.freebsd.org/changeset/ports/515236

Log:
  x11/xfindproxy, x11/xfwp: Deprecate

  Deprecate x11/xfindproxy and x11/xfwp, they are deprecated upstream.
  Make the deprecation timer extra short, since these ports are in the way of
  other updates on x11 land.

  PR:		241314 (related)
  MFH:		2019Q4 (do we MFH deprecation notices?)

Changes:
  head/x11/xfindproxy/Makefile
  head/x11/xfwp/Makefile
Comment 4 Niclas Zeising freebsd_committer 2019-10-23 07:14:39 UTC
Looking at the list, libXp and libXxf86misc are known, and deprecated alreday.  I deprecated xfwp and xfindproxy after checking with upstream that they are deprecated there as well.

I have a fix for mesa-dri in our development tree.  That change is actually related to the libXvMC update that is part of this package, rather than the xorgproto update.  Still, it's a good catch.

Thanks for the help!
Comment 5 Antoine Brodin freebsd_committer 2019-10-23 07:26:31 UTC
Please note that lots of ports were skipped during the exp-run because mesa-dri was broken.
Comment 6 Niclas Zeising freebsd_committer 2019-10-23 07:33:59 UTC
(In reply to Antoine Brodin from comment #5)

Ok, I hadn't thougt of that.  I'll update the patch shortly to continue the exp run then.
Comment 7 Niclas Zeising freebsd_committer 2019-10-23 07:41:08 UTC
Created attachment 208520 [details]
v2

Updated patch with fixes for mesa-dri.  Please continue the exp-run with this patch.

Thank you!
Comment 9 Niclas Zeising freebsd_committer 2019-10-29 10:14:51 UTC
CDE has been broken and deprecated for quite some time.  I plan to remove it at the same time libXp is removed, since it's a dependency.  The other failures are for ports that are already deprecated.

Thanks for your help!
Comment 10 commit-hook freebsd_committer 2019-11-06 17:58:51 UTC
A commit references this bug:

Author: zeising
Date: Wed Nov  6 17:58:30 UTC 2019
New revision: 516911
URL: https://svnweb.freebsd.org/changeset/ports/516911

Log:
  Update xorgproto, libX11 and libXvMC

  Update x11/xorgproto to 2019.2 [0]
  Disable all legacy headers, they are no longer needed, since they only
  detail deprecated protocol features.

  Update x11/libX11 to 1.6.9
  This is a minor update, mostly containing fixes to work with updated
  x11/xorgproto.

  Update x11/libXvMC to  1.0.12 [1]
  This is a minor update, mostly containing fixes to work with updated
  x11/xorgproto.

  Patch mesa prts to explicitly link against -lXv, previously this was pulled
  in by x11/libXvMC, but with changes to libXvMC .pc file, this is no longer
  true.
  Bump portrevision for mesa-dri because of this.

  Thanks fo antoine for the exp-run!

  PR:		241314 (exp-run) [0], 240801 [1]
  Submitted by:	pete@nomadlogic.org [1]

Changes:
  head/graphics/mesa-dri/Makefile
  head/graphics/mesa-dri/files/patch-src_gallium_state__trackers_xvmc_Makefile.in
  head/graphics/mesa-dri/files/patch-src_gallium_targets_xvmc_Makefile.in
  head/x11/libX11/Makefile
  head/x11/libX11/distinfo
  head/x11/libX11/files/
  head/x11/libX11/pkg-plist
  head/x11/libXvMC/Makefile
  head/x11/libXvMC/distinfo
  head/x11/libXvMC/pkg-plist
  head/x11/xorgproto/Makefile
  head/x11/xorgproto/distinfo
  head/x11/xorgproto/pkg-plist
Comment 11 Niclas Zeising freebsd_committer 2019-11-06 18:02:53 UTC
Committed, thanks for all the help!
Comment 12 James Wright 2019-11-14 00:27:22 UTC
I seem to have picked up this package after doing an pkg update/upgrade from the daily repository, and now a bunch of headers seem to have gone missing from my system.


% pkg info xorgproto
xorgproto-2019.2
Name           : xorgproto
Version        : 2019.2
Installed on   : Wed Nov 13 01:14:56 2019 GMT
Origin         : x11/xorgproto
Architecture   : FreeBSD:12:amd64


% sudo pkg check -s xorgproto   
Password:
Checking xorgproto:   0%
xorgproto-2019.2: missing file /usr/local/include/GL/glxint.h
xorgproto-2019.2: missing file /usr/local/include/GL/glxmd.h
xorgproto-2019.2: missing file /usr/local/include/GL/glxproto.h
... (there are many more files listed here)


% cc -DFreeBSD -Wall -Werror -Wextra -Wpedantic -Wno-unknown-pragmas -O2 -pipe -std=c11 -DAUDIO_ALSA -DVIDEO_GLX -Iinc -c src/video/VideoDriverGLX.c -o obj/video/VideoDriverGLX.o
In file included from src/video/VideoDriverGLX.c:13:
In file included from /usr/local/include/GL/glx.h:30:
/usr/local/include/X11/Xlib.h:44:10: fatal error: 'X11/X.h' file not found
#include <X11/X.h>
         ^~~~~~~~~
1 error generated.
gmake: *** [Makefile:130: obj/video/VideoDriverGLX.o] Error 1
Comment 13 James Wright 2019-11-14 00:43:18 UTC
(In reply to James Wright from comment #12)

Fixed by reinstalling the package;

% pkg install -f xorgproto
Comment 14 Niclas Zeising freebsd_committer 2019-11-14 08:28:16 UTC
(In reply to James Wright from comment #13)

Hi!
Are you mixing packages from the quarterly branch and from the daily repository?  That is not supported.
With the update of xorgproto to 2019.2, a lot of legacy headers where removed, although in your case it looks like the files the package installs has simply been removed for some reason.
Comment 15 James Wright 2019-11-14 20:10:13 UTC
(In reply to Niclas Zeising from comment #14)

Nope, I only use packages from daily, perhaps there was some issue with the package build on that day?
Comment 16 James Wright 2019-11-14 20:15:16 UTC
Some other people hit the same problem;

https://forums.freebsd.org/threads/missing-files-in-xorgproto.72989/
Comment 17 Emrion 2019-11-15 09:26:33 UTC
Hi,

Concerning my box, it actually begun its life with quaterly repository and I switched to latest recently. 

That being said, "pkg install -f xorgproto" fixed the problem.
Comment 18 Niclas Zeising freebsd_committer 2019-11-17 13:00:46 UTC
*** Bug 242024 has been marked as a duplicate of this bug. ***