Bug 241324 - java/openjdk8: ignored patch-common-autoconf-toolchain.m4 with "No such line 970 in input file"
Summary: java/openjdk8: ignored patch-common-autoconf-toolchain.m4 with "No such line ...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-java (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-18 10:18 UTC by VVD
Modified: 2019-10-23 15:28 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (java)


Attachments
Fixed "No such line 970 in input file, ignoring" warning message (528 bytes, patch)
2019-10-18 10:18 UTC, VVD
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description VVD 2019-10-18 10:18:00 UTC
Created attachment 208402 [details]
Fixed "No such line 970 in input file, ignoring" warning message

Begin of build log:
===>  License GPLv2 accepted by the user
===>   openjdk8-8.232.09.1_1 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by openjdk8-8.232.09.1_1 for building
===>  Extracting for openjdk8-8.232.09.1_1
=> SHA256 Checksum OK for battleblow-openjdk-jdk8u-8.232.09.1-jdk8u232-b09.1_GH0.tar.gz.
===>  Patching for openjdk8-8.232.09.1_1
===>  Applying extra patch /usr/ports/java/openjdk8/files/fontconfig.patch
===>  Applying FreeBSD patches for openjdk8-8.232.09.1_1
No such line 970 in input file, ignoring
===>   openjdk8-8.232.09.1_1 depends on executable: zip - found
===>   openjdk8-8.232.09.1_1 depends on package: autoconf>0 - found

Caused by changes in common/autoconf/toolchain.m4 - different line numbers.
Ignored %%LOCALBASE%% and used /usr/local always (AFAIU).

Patch tested on 12.0 amd64 and i386.
Comment 1 commit-hook freebsd_committer 2019-10-23 15:28:24 UTC
A commit references this bug:

Author: glewis
Date: Wed Oct 23 15:27:31 UTC 2019
New revision: 515264
URL: https://svnweb.freebsd.org/changeset/ports/515264

Log:
  Fix line numbers so patch can be applied

  PR:		241324
  Submitted by:	VVD <vvd@unislabs.com>

Changes:
  head/java/openjdk8/files/patch-common-autoconf-toolchain.m4
Comment 2 Greg Lewis freebsd_committer 2019-10-23 15:28:54 UTC
Thanks!  Committed