Bug 241332 - portsnap truncated gzip input error
Summary: portsnap truncated gzip input error
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 12.0-RELEASE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
: 241333 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-10-18 19:40 UTC by igor louback
Modified: 2019-10-24 18:02 UTC (History)
3 users (show)

See Also:


Attachments
Picture Error (126.47 KB, image/png)
2019-10-18 19:40 UTC, igor louback
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description igor louback 2019-10-18 19:40:29 UTC
Created attachment 208410 [details]
Picture Error

portsnap is corrupt, need to re - upload it

portsnap fetch
Looking up portsnap.FreeBSD.org mirrors... 6 mirros found.
Fetching snapshot tag from ec2-sa-east-1.portsnap.freebsd.org... done.
Fetching snapshot metadata... done.
Fetching sanpshot generate at Thu Oct 17 21:14:13 -03 2019:
fetch: http://ec2-sa-east-1.portsnap.freebsd.org/s/s65908c1d6287bddbfa812c18cf0865908c1d62870bddbfa812
65908c1d62870bddbfa812c18cf082dc05da2f4d79600a 2641 kB 29 MBps 00s
Extracting snapshot... snap/53c69541d0364c0dd3b58355fe531e886307f4aa1cdf1f89a54af.gz: truncanted gzip input
tar: Error exit delayed from previous erros.
Comment 1 Chris Hutchinson 2019-10-18 19:48:36 UTC
See also:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=241333
Comment 2 igor louback 2019-10-18 21:17:58 UTC
portsnap is corrupt, need to re - upload it

portsnap fetch
Looking up portsnap.FreeBSD.org mirrors... 6 mirros found.
Fetching snapshot tag from ec2-sa-east-1.portsnap.freebsd.org... done.
Fetching snapshot metadata... done.
Fetching sanpshot generate at Thu Oct 17 21:14:13 -03 2019:
fetch: http://ec2-sa-east-1.portsnap.freebsd.org/s/s65908c1d6287bddbfa812c18cf0865908c1d62870bddbfa812
65908c1d62870bddbfa812c18cf082dc05da2f4d79600a 2641 kB 29 MBps 00s
Extracting snapshot... snap/53c69541d0364c0dd3b58355fe531e886307f4aa1cdf1f89a54af.gz: truncanted gzip input
tar: Error exit delayed from previous erros.
Comment 3 Kurt Jaeger freebsd_committer 2019-10-19 07:14:39 UTC
*** Bug 241333 has been marked as a duplicate of this bug. ***
Comment 4 Kurt Jaeger freebsd_committer 2019-10-19 07:16:23 UTC
Did an poudriere ports -u, connected to ec2-eu-west-1.portsnap.freebsd.org,
this has a valid portsnap file. How to test ec2-sa-east-1.portsnap.freebsd.org ?
Comment 5 Kurt Jaeger freebsd_committer 2019-10-19 07:22:41 UTC
tested with
portsnap -s ec2-sa-east-1.portsnap.freebsd.org -p . fetch
this worked fine, so: problem solved.
Comment 6 igor louback 2019-10-19 12:32:14 UTC
thank you
Comment 7 koji 2019-10-21 15:53:27 UTC
Issue with ec2-sa-east-1.portsnap.freebsd.org seems to be back again:

srv1# portsnap fetch
Looking up portsnap.FreeBSD.org mirrors... 6 mirrors found.
Fetching snapshot tag from ec2-sa-east-1.portsnap.freebsd.org... done.
Fetching snapshot metadata... done.
Updating from Mon Sep 30 12:49:27 UTC 2019 to Mon Oct 21 13:13:31 UTC 2019.
Fetching 5 metadata patches... done.
Applying metadata patches... done.
Fetching 5 metadata files... /usr/sbin/portsnap: cannot open 09c13008d90691224b14e1ccb9b321abdd890f19cf6476113508627cbf7576d3.gz: No such file or directory
metadata is corrupt.

I've managed to use another mirror for now, but it'd be good to have it fixed.

srv2# portsnap -s ec2-eu-west-1.portsnap.freebsd.org fetch
Looking up ec2-eu-west-1.portsnap.freebsd.org mirrors... none found.
Fetching snapshot tag from ec2-eu-west-1.portsnap.freebsd.org... done.
Latest snapshot on server matches what we already have.
No updates needed.

srv2# portsnap -s ec2-ap-southeast-2.portsnap.freebsd.org fetch
Looking up ec2-ap-southeast-2.portsnap.freebsd.org mirrors... none found.
Fetching snapshot tag from ec2-ap-southeast-2.portsnap.freebsd.org... done.
Latest snapshot on server matches what we already have.
No updates needed.

srv2# portsnap -s ec2-sa-east-1.portsnap.freebsd.org fetch
Looking up ec2-sa-east-1.portsnap.freebsd.org mirrors... none found.
Fetching snapshot tag from ec2-sa-east-1.portsnap.freebsd.org... done.
Latest snapshot on server is older than what we already have!
Cowardly refusing to downgrade from Mon Oct 21 11:44:14 -03 2019
to Mon Oct 21 10:13:31 -03 2019.
Comment 8 Kurt Jaeger freebsd_committer 2019-10-21 16:05:46 UTC
Tested, problem is indeed back.
Comment 9 Kurt Jaeger freebsd_committer 2019-10-21 19:11:55 UTC
This is a ticket for the secteam according to clusteradm@
Comment 10 Kurt Jaeger freebsd_committer 2019-10-23 06:29:22 UTC
portsnap -s ec2-sa-east-1.portsnap.freebsd.org -p . fetch

worked again.