Bug 241341 - x11/plasma5-plasma-workspace: blank screen with cursor after logging in
Summary: x11/plasma5-plasma-workspace: blank screen with cursor after logging in
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-19 13:10 UTC by Martin Birgmeier
Modified: 2019-10-20 18:16 UTC (History)
3 users (show)

See Also:
rakuco: maintainer-feedback+


Attachments
log of kstart5 plasmashell (32.36 KB, text/plain)
2019-10-19 13:10 UTC, Martin Birgmeier
no flags Details
XDG environment variable before applying comment #4 (382 bytes, text/plain)
2019-10-19 15:20 UTC, Martin Birgmeier
no flags Details
Possible fix (1.69 KB, patch)
2019-10-19 16:49 UTC, Tobias C. Berner
no flags Details | Diff
Possible Fix v2 (2.26 KB, patch)
2019-10-19 17:01 UTC, Tobias C. Berner
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Birgmeier 2019-10-19 13:10:01 UTC
Created attachment 208419 [details]
log of kstart5 plasmashell

Scenario:
- FreeBSD 12.0
- sddm
- Update of kf5 to 5.63.0 yesterday using portmaster

Result:
- On next login (with intervening reboot), the last step of the initial plasma startup wait box takes a long time
- Then the screen shows
  . nothing (for a user with an empty home directory)
  . a restored xterm and xload (for a user which had this running on the last logout/shutdown)
- The screen also shows the cursor

Scenario (continued):
- Start typing in the background screen
- A box appears, use it to start an xterm
- In the xterm, type 'kstart5 plasmashell > /tmp/kstart5.plasmashell.log 2>&1'

Result:
- The plasma desktop starts
- However, the 'Favorites' and 'Applications' menus of the application launcher ("start button") are completely empty
- When opening, e.g., dolphin via the command line, the system does not know any file associations and for each clicked file prompts asking which program to use to open it
- The (attached) logfile shows issues which seem to corroborate these observations
Comment 1 Martin Birgmeier 2019-10-19 13:11:18 UTC
Btw, I am using an nvidia graphics card with the latest driver (from ports).
Comment 2 Martin Birgmeier 2019-10-19 13:26:19 UTC
Just tried it on another machine which was updated yesterday and which is not using nvidia (old radeon card). The same result happens: blank screen with cursor.

An xterm can be started (from another console after switching to it using ctl-alt-Fn), and from there again the 'kstart5 plasmashell', which exhibits mostly the same output.
Comment 3 Raphael Kubo da Costa freebsd_committer 2019-10-19 14:49:45 UTC
From #kde-freebsd on IRC, this could be https://bugs.kde.org/show_bug.cgi?id=413130
Comment 4 Tobias C. Berner freebsd_committer 2019-10-19 14:52:24 UTC
Hi there

Can you extend your .xinitrc to set the following variables (prior to the 'exec ... ' line).

XDG_CONFIG_DIRS=${XDG_CONFIG_DIRS}:/etc/xdg:/usr/local/etc/xdg:/usr/local/etc/xdg/xfce 
export XDG_CONFIG_DIRS

XDG_DATA_DIRS=${XDG_DATA_DIRS}:/usr/share:/usr/local/share:/usr/local/share/gnome
export XDG_DATA_DIRS


mfg Tobias
Comment 5 Martin Birgmeier 2019-10-19 15:20:00 UTC
Created attachment 208420 [details]
XDG environment variable before applying comment #4

Thank you, this fixed it.

See the attached file for how the XDG environment variables looked before this change (using the command "env | grep XDG").

-- Martin
Comment 6 Tobias C. Berner freebsd_committer 2019-10-19 16:49:58 UTC
Created attachment 208421 [details]
Possible fix

Hi Martin 

Could you remove the variables again and try with a recompiled plasma5-plasma-workspace with applied patch?


mfg Tobias
Comment 7 Tobias C. Berner freebsd_committer 2019-10-19 17:01:26 UTC
Created attachment 208422 [details]
Possible Fix v2

Sorry, forgot to define KDE_INSTALL_FULL_CONFDIR in the previous patch...
Comment 8 commit-hook freebsd_committer 2019-10-19 17:12:45 UTC
A commit references this bug:

Author: tcberner
Date: Sat Oct 19 17:12:26 UTC 2019
New revision: 514822
URL: https://svnweb.freebsd.org/changeset/ports/514822

Log:
  x11/plasma5-plasma-workspace: setup XDG_CONFIG_DIRS on startup if not set

  In prior versions of KDE's Plasma Desktop we set XDG_CONFIG_DIRS in the startkde
  shellscript. Plasma 5.17 changed to a binary for this process and that variable
  therefore was no longer set for most people (unless manually done so in their
  environment / .xinitrc file, like me...).

  With this patch the variable is now again setup, startplasma should be able to
  bring up the whole shell again.

  PR:		241341
  Reported by:	Martin Birgmeier

Changes:
  head/x11/plasma5-plasma-workspace/Makefile
  head/x11/plasma5-plasma-workspace/files/patch-setup_xdg_environment
Comment 9 Martin Birgmeier 2019-10-19 17:54:13 UTC
Hi Tobias,

Thank you for the fix, I did not find the time yet to apply it, but since you already committed it you seem to be sure it works. :-)

One question though: How does Linux do this?

-- Martin
Comment 10 Martin Birgmeier 2019-10-20 18:16:04 UTC
Post scriptum: I installed the new plasma port and removed the settings of XGD_* from .xinintrc. As expected everything works.

-- Martin