Bug 241394 - lang/perl5.30: /usr/local/bin/perl5 is no longer symlinked to perl
Summary: lang/perl5.30: /usr/local/bin/perl5 is no longer symlinked to perl
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mathieu Arnold
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-21 12:44 UTC by martin
Modified: 2019-11-12 19:08 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (mat)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description martin 2019-10-21 12:44:33 UTC
Previous versions (lang/perl5.2x) symlinked /usr/local/bin/perl5 to perl, but this link is missing from lang/perl5.30.  If this is by designed then I think it should be mentioned when doing "pkg upgrade" because it breaks BWC.
Comment 1 Mathieu Arnold freebsd_committer 2019-11-12 15:48:08 UTC
The perl5 symlink was never a thing, it was a FreeBSD oddity.  Before removing it, I checked most of the software in the ports tree using Perl, and none used "perl5", they either used "perl" or a computed "perlX.YY.Z".  I have no idea what BWC is but it should probably be fixed instead.
Comment 2 martin 2019-11-12 19:08:17 UTC
BWC means "backward compatibility" (sorry, it seems that this is not a common way of writing it).  The removed symlink is a problem for user-written scripts rather than ports.