Bug 241399 - Bhyve crashes, won't start
Summary: Bhyve crashes, won't start
Status: Closed DUPLICATE of bug 241467
Alias: None
Product: Base System
Classification: Unclassified
Component: bhyve (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-virtualization mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-21 20:10 UTC by Nathan
Modified: 2019-10-24 13:58 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan 2019-10-21 20:10:09 UTC
Bhyve crashes on r353798M on 13-Current , only error it gives me is Abort Trap(Core dump), not sure what else I can do to give more info, like debugging and such, as I have no experience in what tools and how to return debugging info from them.
Comment 1 Andrey Fesenko 2019-10-24 13:02:50 UTC
Confirm, tested r353887 and r354013, freebsd and linux bhyve guests

 lldb -c /bhyve.core /usr/sbin/bhyve
 (lldb) target create "/usr/sbin/bhyve" --core "/bhyve.core"
 Core file '/bhyve.core' (x86_64) was loaded.
 (lldb) bt
 * thread #1, name = 'bhyve', stop reason = signal SIGABRT
  * frame #0: 0x00000008007fa50a libc.so.7`__sys_thr_kill at thr_kill.S:4
    frame #1: 0x00000008007f9eb4 libc.so.7`__raise(s=6) at raise.c:52:10
    frame #2: 0x000000080076de39 libc.so.7`abort at abort.c:67:8
    frame #3: 0x00000008007e8131 libc.so.7`__assert(func=<unavailable>,   file=<unavailable>, line=<unavailable>, failedexpr=<unavailable>) at assert.c:51:2
    frame #4: 0x000000000021fb42 bhyve`main(argc=<unavailable>, argv=<unavailable>) at bhyverun.c:1190:3
    frame #5: 0x000000000021b10f bhyve`_start(ap=<unavailable>, cleanup=<unavailable>) at crt1.c:76:7
 (lldb) quit
Comment 3 Jung-uk Kim freebsd_committer 2019-10-24 13:58:48 UTC

*** This bug has been marked as a duplicate of bug 241467 ***