Bug 241469 - [NEW PORT] net-im/6cord: Terminal-driven Discord client.
Summary: [NEW PORT] net-im/6cord: Terminal-driven Discord client.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitri Goutnik
URL: https://gitlab.com/diamondburned/6cord
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-24 13:57 UTC by Lewis Cook
Modified: 2019-10-29 22:58 UTC (History)
1 user (show)

See Also:


Attachments
port diff (17.11 KB, patch)
2019-10-24 13:57 UTC, Lewis Cook
no flags Details | Diff
Updated port diff (17.90 KB, patch)
2019-10-25 15:00 UTC, Lewis Cook
lcook: maintainer-approval-
Details | Diff
Final port diff (17.11 KB, patch)
2019-10-26 09:57 UTC, Lewis Cook
lcook: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lewis Cook freebsd_committer freebsd_triage 2019-10-24 13:57:23 UTC
Created attachment 208569 [details]
port diff

Fast, lightweight opensource terminal-driven
client for Discord written in go.

WWW: https://gitlab.com/diamondburned/6cord

QA: portlint: looks fine. Poudriere: built successfully without error and application works as expected.
Comment 1 Dmitri Goutnik freebsd_committer 2019-10-25 13:52:26 UTC
(In reply to Lewis Cook from comment #0)
Hi,

Thank you for the new port contribution. I noticed two things during testing:

(1) GL_COMMIT doesn't correspond to the "stable-9.2" tag, shouldn't it be 9bbca67ccee21445df72b2f734941abc7d09a0c9 instead?

(2) The port in its current state doesn't build on i386:

# gitlab.com/diamondburned/6cord
./main.go:452:2: undefined: syscallSilenceStderr

This is caused by incorrect build tags in syscall.go and syscall_unix.go - there's no GOOS "unix" so both files are excluded from build when GOARCH is i386. It needs to be patched (and upstreamed) or port needs ONLY_FOR_ARCHS=amd64.
Comment 2 Lewis Cook freebsd_committer freebsd_triage 2019-10-25 14:59:54 UTC
(In reply to Dmitri Goutnik from comment #1)

Oops, didn't catch that, cheers! I'll re-submit the diff.
Comment 3 Lewis Cook freebsd_committer freebsd_triage 2019-10-25 15:00:51 UTC
Created attachment 208598 [details]
Updated port diff

Changes:

* Updated 'GL_COMMIT' as requested (as-well-as preliminary values, 'GL_TUPLE', 'GH_TUPLE', distinfo, etc, ...);
* Set 'ONLY_FOR_ARCHS= amd64' in the Makefile (I have no intentions of supporting i386, although I'm open to patches);
* Included a patch that reverts debug info being printed whilst using the application (see: files/patch-main.go).
Comment 4 Lewis Cook freebsd_committer freebsd_triage 2019-10-25 17:20:48 UTC
Created a pull request earlier that fixes the build-tags and dup2 syscall error: https://gitlab.com/diamondburned/6cord/merge_requests/19 - unbreaking 32bit compilation.

Waiting to get a response back, then I'll update the port to the latest release.
Comment 5 Lewis Cook freebsd_committer freebsd_triage 2019-10-26 09:57:06 UTC
Created attachment 208603 [details]
Final port diff

My patch was merged upstream, fixing the previous issues of compilation on i386.

Changes:

* Updated Makefile to the latest tag release (9.5);
* Updated 'GL_COMMIT', 'GL_TUPLE', 'distinfo', etc, ...;
* Removed 'ONLY_FOR_ARCHS=amd64' as the previous issues has been fixed;
* Removed files/patch-main.go as the DEBUG info being leaked has been fixed in the latest release.
Comment 6 Lewis Cook freebsd_committer freebsd_triage 2019-10-26 09:59:52 UTC
(In reply to Dmitri Goutnik from comment #1)
Able to compile for i386 now. Can you confirm this on your side too please, cheers. Everything else seems good to go.

QA: portlint passed. Poudriere built the package as expected, and now compiles for i386. Application works as expected.
Comment 7 commit-hook freebsd_committer 2019-10-29 22:58:31 UTC
A commit references this bug:

Author: dmgk
Date: Tue Oct 29 22:57:50 UTC 2019
New revision: 516039
URL: https://svnweb.freebsd.org/changeset/ports/516039

Log:
  New port: net-im/6cord

  Fast, lightweight opensource terminal-driven
  client for Discord written in go.

  WWW: https://gitlab.com/diamondburned/6cord

  PR:		241469
  Submitted by:	Lewis Cook <vulcan@wired.sh>
  Approved by:	tz (mentor)
  Differential Revision:	https://reviews.freebsd.org/D22152

Changes:
  head/net-im/6cord/
  head/net-im/6cord/Makefile
  head/net-im/6cord/distinfo
  head/net-im/6cord/files/
  head/net-im/6cord/files/pkg-message.in
  head/net-im/6cord/pkg-descr
  head/net-im/Makefile
Comment 8 Dmitri Goutnik freebsd_committer 2019-10-29 22:58:59 UTC
Committed with some changes, thanks!