Bug 241482 - lang/pocl: failed with 'Undefined symbol "clGetPlatformInfo"'
Summary: lang/pocl: failed with 'Undefined symbol "clGetPlatformInfo"'
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jan Beich
URL:
Keywords: needs-qa, regression
Depends on:
Blocks: 241243
  Show dependency treegraph
 
Reported: 2019-10-25 02:42 UTC by Jan Beich
Modified: 2020-12-12 10:53 UTC (History)
3 users (show)

See Also:


Attachments
patch that fixes the problem (408 bytes, patch)
2020-10-09 18:02 UTC, Lars Herschke
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2019-10-25 02:42:17 UTC
$ pkg install pocl clpeak
$ clpeak

Platform: Portable Computing Language
  Device: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
    Driver version  : 1.4 (FreeBSD)
    Compute units   : 8
    Clock frequency : 4601 MHz

    Global memory bandwidth (GBPS)
      float   : clEnqueueNDRangeKernel (-63)
      Tests skipped

    Single-precision compute (GFLOPS)
clCreateBuffer (-61)
      Tests skipped

    No half precision support! Skipped

    Double-precision compute (GFLOPS)
clCreateBuffer (-61)
      Tests skipped

    Integer compute (GIOPS)
clCreateBuffer (-61)
      Tests skipped

    Transfer bandwidth (GBPS)
      enqueueWriteBuffer         : 0.00
      enqueueReadBuffer          : 0.00
      enqueueMapBuffer(for read) : 0.00
        memcpy from mapped ptr   : inf
      enqueueUnmap(after write)  : 0.00
        memcpy to mapped ptr     : inf

    Kernel launch latency : dlopen("/home/foo/.cache/pocl/kcache/JH/IDMFGLODMLKNOOOIDKINDHECPPKMGBKLEIOBN/global_bandwidth_v1_local_offset/256-1-1-goffs0-smallgrid/global_bandwidth_v1_local_offset.so") failed with 'Undefined symbol "clGetPlatformInfo"'.
note: missing symbols in the kernel binary might be reported as 'file not found' errors.
Abort trap
Comment 1 Jan Beich freebsd_committer 2019-10-25 02:50:45 UTC
Not reproducible with 1.3 (previous version).
Comment 2 O. Hartmann 2019-10-26 10:10:59 UTC
It affects me, too. Think this is a bug affecting many people.
Comment 3 Lars Herschke 2020-10-09 18:02:49 UTC
Created attachment 218627 [details]
patch that fixes the problem

The displayed error does not come from the dlopen call but from the last dlsym call in the icd loader.
Including a patch that solves the problem.
Comment 4 Lars Herschke 2020-10-09 22:19:31 UTC
The problem was caused by the change from libltdl to libdl in version 1.4. Therefore, the dependency on libltdl.so in the Makefile is actually superfluous.
Comment 5 commit-hook freebsd_committer 2020-12-12 10:44:14 UTC
A commit references this bug:

Author: jbeich
Date: Sat Dec 12 10:44:07 UTC 2020
New revision: 557808
URL: https://svnweb.freebsd.org/changeset/ports/557808

Log:
  lang/pocl: unbreak runtime after r514525

  PR:		241482
  Submitted by:	Lars Herschke
  Approved by:	maintainer timeout (2 months)

Changes:
  head/lang/pocl/Makefile
  head/lang/pocl/distinfo
Comment 6 commit-hook freebsd_committer 2020-12-12 10:53:19 UTC
A commit references this bug:

Author: jbeich
Date: Sat Dec 12 10:52:33 UTC 2020
New revision: 557810
URL: https://svnweb.freebsd.org/changeset/ports/557810

Log:
  MFH: r557808

  lang/pocl: unbreak runtime after r514525

  PR:		241482
  Submitted by:	Lars Herschke
  Approved by:	maintainer timeout (2 months)

Changes:
_U  branches/2020Q4/
  branches/2020Q4/lang/pocl/Makefile
  branches/2020Q4/lang/pocl/distinfo