Bug 241493 - Some sys.netinet6 tests failed or timeout on i386
Summary: Some sys.netinet6 tests failed or timeout on i386
Status: Closed DUPLICATE of bug 239380
Alias: None
Product: Base System
Classification: Unclassified
Component: tests (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: Bjoern A. Zeeb
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-25 21:29 UTC by Li-Wen Hsu
Modified: 2019-11-08 18:02 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Li-Wen Hsu freebsd_committer 2019-10-25 21:29:59 UTC
FreeBSD-head-i386-test job failed because of timeout, following 

sys/netinet6/frag6/frag6_01:frag6_01  ->  skipped: Sending IPv6 Jumbograms needs 1 kernel changes and BPF fixes  [0.039s]
sys/netinet6/frag6/frag6_02:frag6_02  ->  lock order reversal:
 1st 0x1e24e9c allprison (allprison) @ /usr/src/sys/kern/kern_jail.c:966
 2nd 0x1e36158 vnet_sysinit_sxlock (vnet_sysinit_sxlock) @ /usr/src/sys/net/vnet.c:574
stack backtrace:
#0 0x10273f1 at witness_debugger+0x61
#1 0x10271e1 at witness_checkorder+0x901
#2 0xfcf949 at _sx_slock_int+0x49
#3 0x10df601 at vnet_alloc+0xf1
#4 0xf9078b at kern_jail_set+0x185b
#5 0xf91f08 at sys_jail_set+0x38
#6 0x13ff41b at syscall+0x2db
#7 0xffc033b7 at next_index+0xda910213
broken: Test case body timed out  [300.063s]
sys/netinet6/frag6/frag6_03:frag6_03  ->  broken: Test case body timed out  [300.012s]
sys/netinet6/frag6/frag6_04:frag6_04  ->  broken: Test case body timed out  [300.076s]
sys/netinet6/frag6/frag6_05:frag6_05_0  ->  passed  [25.882s]
sys/netinet6/frag6/frag6_05:frag6_05_1  ->  passed  [26.078s]
sys/netinet6/frag6/frag6_06:frag6_06_0  ->  passed  [25.884s]
sys/netinet6/frag6/frag6_07:frag6_07  ->  failed: atf-check failed; see the output of the test for details  [93.969s]
sys/netinet6/frag6/frag6_08:frag6_08  ->  failed: atf-check failed; see the output of the test for details  [94.105s]
sys/netinet6/frag6/frag6_09:frag6_09  ->  failed: atf-check failed; see the output of the test for details  [93.963s]
sys/netinet6/frag6/frag6_10:frag6_10  ->  passed  [4.952s]
sys/netinet6/frag6/frag6_11:frag6_11  ->  passed  [80.077s]
sys/netinet6/frag6/frag6_12:frag6_12  ->  failed: atf-check failed; see the output of the test for details  [93.769s]
sys/netinet6/frag6/frag6_13:frag6_13  ->  passed  [8.182s]
sys/netinet6/frag6/frag6_14:frag6_14  ->  passed  [10.363s]
sys/netinet6/frag6/frag6_15:frag6_15  ->  failed: Interface ICMPv6 statistics do not match: 19 != 21  [12.545s]
sys/netinet6/frag6/frag6_16:frag6_16  ->  failed: atf-check failed; see the output of the test for details  [93.965s]
sys/netinet6/frag6/frag6_17:frag6_17  ->  passed  [141.023s]
sys/netinet6/frag6/frag6_18:frag6_18  ->  passed  [140.780s]
sys/netinet6/frag6/frag6_19:frag6_19  ->  failed: Global IPv6 statistics do not match: 19 != 20  [140.749s]

Test VM image is available at https://artifact.ci.freebsd.org/snapshot/head/r354028/i386/i386/disk-test.img.xz
Comment 1 Li-Wen Hsu freebsd_committer 2019-10-25 21:39:43 UTC
 Temporarily disable sys.netinet6.frag6 on i386:

https://github.com/freebsd/freebsd-ci/commit/5c62fe1426ee3988f407a9b22e314f03031eee8e
Comment 2 Bjoern A. Zeeb freebsd_committer 2019-10-26 16:57:32 UTC
Probably the same reason as with the netpfil tests.  Let's cleanup the scapy / python parts and see again.
Comment 3 commit-hook freebsd_committer 2019-11-05 10:54:42 UTC
A commit references this bug:

Author: bz
Date: Tue Nov  5 10:53:56 UTC 2019
New revision: 354357
URL: https://svnweb.freebsd.org/changeset/base/354357

Log:
  frag6 tests: set end to catch timeout as error

  There are times when we have to wait for reply packets.  There are
  either an ICMPv6 (error) reply or the expiration timeout.
  In these cases synchonous ICMPv6 replies should arrive, always,
  unless the packet is lost.  Due to errors experienced with the
  test software sending an invlaid request on at least i386 (*) these
  packets are not generated.  That means we are waiting for a long time
  for the replies or even timeout the test case.

  Manually set the "End" flag on these test cases as well, so they do
  fail rather than timeout as the sniffer timeout happens.  This improves
  debugging options, reflects the error properly, and saves time on each
  test suit run.

  (*) The real cause for that is still to be found (see the referenced PRs)

  PR:			241493, 239380
  MFC after:		2 weeks
  Sponsored by:		Netflix

Changes:
  head/tests/sys/netinet6/frag6/frag6_02.py
  head/tests/sys/netinet6/frag6/frag6_04.py
Comment 4 Bjoern A. Zeeb freebsd_committer 2019-11-05 17:44:39 UTC
*** Bug 241739 has been marked as a duplicate of this bug. ***
Comment 5 commit-hook freebsd_committer 2019-11-05 17:50:12 UTC
A commit references this bug:

Author: lwhsu
Date: Tue Nov  5 17:49:16 UTC 2019
New revision: 354362
URL: https://svnweb.freebsd.org/changeset/base/354362

Log:
  Temporarily disable sys.netinet6.exthdr on i386

  PR:		241493
  Sponsored by:	The FreeBSD Foundation

Changes:
  head/tests/sys/netinet6/exthdr.sh
Comment 6 Bjoern A. Zeeb freebsd_committer 2019-11-06 13:16:13 UTC
Let's track them all on one PR only as otherwise patches will go everywhere.

*** This bug has been marked as a duplicate of bug 239380 ***