Bug 241500 - lang/beignet: installed with lang/pocl results in: LLVM ERROR: inconsistency in registered CommandLine options
Summary: lang/beignet: installed with lang/pocl results in: LLVM ERROR: inconsistency ...
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: patch
Depends on: 233495
Blocks:
  Show dependency treegraph
 
Reported: 2019-10-26 13:44 UTC by O. Hartmann
Modified: 2020-04-02 18:17 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2019-10-26 13:44:38 UTC
This issue is long standing and with the recent ports tree and POCL 1.4 and LLVM 8.0/LLVM 9.0 it can be reduced to the parallel installation of lang/beignet (beignet-1.3.2_8 as for now). With lang/pocl installed, any OpenCL using application fails with the error:

:  CommandLine Error: Option 'limited-coverage-experimental' registered more than once! LLVM ERROR: inconsistency in registered CommandLine options

The problem can be simply reproduced by installing port devel/clinfo and/or benchmarks/clpeak, issuing "clinfo" for instance on the command line, when lang/pocl and lang/beignet are installed parallel.

This issue has been reported since POCL 0.14 (i.e. Bug 219562).

In all cases I've tested, devel/ocl-icd is also installed and used.

This issue has been reported upstream in 2017, see

https://github.com/pocl/pocl/issues/474

and has been also dicussed here with the LLVM backend:

https://bugs.llvm.org/show_bug.cgi?id=30587
Comment 2 Rene Ladan freebsd_committer 2020-04-02 18:17:27 UTC
lang/beignet expired today, please use lang/intel-compute-runtime instead.