Bug 241539 - mail/spamd: obspamlogd does not start, no documentation found
Summary: mail/spamd: obspamlogd does not start, no documentation found
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Olli Hauer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-28 12:47 UTC by oz42
Modified: 2020-06-17 17:20 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ohauer)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description oz42 2019-10-28 12:47:20 UTC
First start failed:

# /usr/local/etc/rc.d/obspamlogd start
Starting obspamlogd.
spamlogd: /var/db/spamd: No such file or directory


As there is no documentation:

# man obspamlogd
No manual entry for obspamlogd


I tried to create an empty file:

# touch /var/db/spamd


But start still fails:

# /usr/local/etc/rc.d/obspamlogd start
Starting obspamlogd.
spamlogd: couldn't initialize pcap: Device not configured
/usr/local/etc/rc.d/obspamlogd: WARNING: failed to start obspamlogd


So please add a link to a HOWTO to the "make install" information output.
Comment 1 Olli Hauer freebsd_committer 2020-06-17 17:20:56 UTC
sorry for delay.

since there is a conflict with spamd from spamassassin the binary was prefixed with ob (for OpenBSD), however manpages are not prefixed 

pkg info -l spamd | grep man
        /usr/local/man/man5/spamd.conf.5.gz
        /usr/local/man/man8/spamd-setup.8.gz
        /usr/local/man/man8/spamd.8.gz
        /usr/local/man/man8/spamdb.8.gz
        /usr/local/man/man8/spamlogd.8.gz

# touch /var/db/spamd
Not required, the database /var/db/spamd will be created by the first run of spamd.

# spamlogd: couldn't initialize pcap: Device not configured
Running kldload pflog will solve this issue, not sure why this was not done by the obspamlogd start script in your case since the kldload instructions are in the precmd section and starting should fail with "Unable to kldload pflog module"