Bug 241542 - emulators/qemu-user-static: Add support for reading AArch64 Instruction Set Attribute/Processor Feature registers
Summary: emulators/qemu-user-static: Add support for reading AArch64 Instruction Set A...
Status: Closed DUPLICATE of bug 240037
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sean Bruno
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-28 15:04 UTC by Dmitri Goutnik
Modified: 2019-10-28 20:22 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (sbruno)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitri Goutnik freebsd_committer 2019-10-28 15:04:49 UTC
Support for freebsd/arm64 is in the process of getting merged by the Go Project and while the build works on real hardware, it currently fails with signal 4 Illegal Instruction under qemu-user-static emulation of aarch64 due to the missing support for reading ID_AA64ISAR{0,1}_EL1 and ID_AA64PFR0_EL1 registers [1], [2]

[1] https://github.com/golang/go/blob/master/src/runtime/os_freebsd_arm64.go#L40
[2] https://github.com/golang/go/blob/master/src/runtime/sys_freebsd_arm64.s#L521
Comment 1 Mikael Urankar freebsd_committer 2019-10-28 16:44:07 UTC
duplicate bug #240037
Comment 2 Dmitri Goutnik freebsd_committer 2019-10-28 20:22:35 UTC

*** This bug has been marked as a duplicate of bug 240037 ***