Bug 241579 - FreeBSD i386 sendmail broken for STARTTLS
Summary: FreeBSD i386 sendmail broken for STARTTLS
Status: Closed Feedback Timeout
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 12.0-RELEASE
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-29 23:25 UTC by tedm
Modified: 2020-10-29 08:30 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tedm 2019-10-29 23:25:58 UTC
FreeBSD i386 cannot be configured to run TLS on Sendmail.  FreeBSD arm64 works fine using the identical instructions.  OpenSSL will generate a self signed certificate if it is defined in /etc/rc.conf for sendmail but sendmail errors out when attempting to load it.
Comment 1 Eugene Grosbein freebsd_committer 2020-08-01 09:30:09 UTC
Sendmail got some TLS-related fixes after 12.1-RELEASE. Could you please verify if the problem is still relevant for 12-STABLE?