Bug 241592 - www/firefox not displaying check boxes on most sites
Summary: www/firefox not displaying check boxes on most sites
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gecko mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-30 17:22 UTC by Dwayne MacKinnon
Modified: 2019-11-26 19:10 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (gecko)


Attachments
PNG of firefox showing mobileread.com forums. (212.17 KB, image/png)
2019-10-30 17:22 UTC, Dwayne MacKinnon
no flags Details
PNG of konqueror showing mobileread.com/forums. (388.26 KB, image/png)
2019-10-30 17:23 UTC, Dwayne MacKinnon
no flags Details
gedit and Firefox with Breeze (553.64 KB, image/png)
2019-11-01 05:18 UTC, Graham Perrin
no flags Details
gedit and Firefox with Greybird (613.50 KB, image/png)
2019-11-01 05:20 UTC, Graham Perrin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dwayne MacKinnon 2019-10-30 17:22:59 UTC
Created attachment 208703 [details]
PNG of firefox showing mobileread.com forums.

I'm running Firefox (firefox-70.0_3,1) on FreeBSD 12.0-RELEASE-p10, amd64. I'm completely unsure as to why, but on most websites firefox isn't displaying checkboxes well. I've attached a screenshot to demonstrate. In the Konquereor_checkbox.png screenshot, you can clearly see the checkbox in the Login area next to the "Remember me" line. On Firefox you can't see it.

Just in case it was a plasma desktop thing, I also tried it on firefox in twm. Same results.
Comment 1 Dwayne MacKinnon 2019-10-30 17:23:44 UTC
Created attachment 208704 [details]
PNG of konqueror showing mobileread.com/forums.
Comment 2 Jan Beich freebsd_committer 2019-10-30 18:06:15 UTC
Comment on attachment 208703 [details]
PNG of firefox showing mobileread.com forums.

Try disabling custom Gtk3 theme. Adwaita (default) should work fine.
Comment 3 Jan Beich freebsd_committer 2019-10-30 18:17:05 UTC
Comment on attachment 208704 [details]
PNG of konqueror showing mobileread.com/forums.

Invalid comparison. Notice how buttons are styled. Firefox uses Gtk while Konqueror uses Qt. Unless Qt is confugured to use Gtk themes via compatibility layer (e.g., x11-toolkits/qt5-gtkplatform) both are not going to look the same.
Comment 4 Graham Perrin 2019-10-31 13:25:10 UTC
I found the same (symptoms with check boxes etc.) following a recent round of updates to FreeBSD-CURRENT. 

Not limited to Firefox; Remmina and various other applications are affected. 

Affected themes include Breeze. I imagine that there's already a bug report somewhere. 

Worked around here with Greybird theme for GTK2 and GTK3. YMMV.
Comment 5 Dwayne MacKinnon 2019-10-31 15:04:07 UTC
(In reply to Jan Beich from comment #2 and #3)

Firstly, thanks for pointing me at the GTK3 theme. Moving it from Breeze to default has fixed the problem for me.

My issue wasn't that they didn't look the same; it's that I couldn't see the checkbox at all. I used Konqueror for a comparison to show that I could see the checkbox in another browser.

To be clear: until recently, I never had a problem seeing checkboxes in Firefox no matter which site I visited, including mobileread.com.

Doing some searching around KDE's bugzilla it appears like the issue may be this one: https://bugs.kde.org/show_bug.cgi?id=412078
Comment 6 Graham Perrin 2019-11-01 05:18:09 UTC
Created attachment 208753 [details]
gedit and Firefox with Breeze
Comment 7 Graham Perrin 2019-11-01 05:20:35 UTC
Created attachment 208754 [details]
gedit and Firefox with Greybird

Greybird theme – working around whatever bugs the window controls etc. in gedit; and the radio buttons etc. in Firefox …
Comment 8 VVD 2019-11-26 19:10:49 UTC
I had same issue, but it was fixed in release 70.0.