Bug 241614 - devel/pecl-APCu: Update to 5.1.18 and unbreak with PHP74
Summary: devel/pecl-APCu: Update to 5.1.18 and unbreak with PHP74
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Jochen Neumeister
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-31 09:48 UTC by Pascal Christen
Modified: 2019-11-07 11:34 UTC (History)
1 user (show)

See Also:
pascal.christen: maintainer-feedback-


Attachments
Update (834 bytes, patch)
2019-10-31 09:48 UTC, Pascal Christen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pascal Christen 2019-10-31 09:48:30 UTC
Release notes
Version 5.1.18

- Implement apcu_inc() and apcu_dec() using atomic operations. This means that these functions no longer have to acquire a write lock. These functions will now wraparound on overflow, instead of saturating to a floating point value.
- Make table header in apc.php sticky.
- Fix compile warnings related to mktemp() usage.
- Fix compatibility with PHP 8.0.
- Fix required number of arguments for apcu_store() returned by Reflection.
Comment 1 Pascal Christen 2019-10-31 09:48:54 UTC
Created attachment 208729 [details]
Update
Comment 2 Pascal Christen 2019-11-07 00:21:49 UTC
Port got updated without unbreak with PHP7.4 or mentioned anything...
Comment 3 Jochen Neumeister freebsd_committer 2019-11-07 11:34:02 UTC
fixed in r516940