Bug 241626 - mail/rspamd: [patch] add OpenBLAS support for KANN in Rspamd
Summary: mail/rspamd: [patch] add OpenBLAS support for KANN in Rspamd
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Vsevolod Stakhov
URL:
Keywords:
: 242092 (view as bug list)
Depends on: 238228
Blocks:
  Show dependency treegraph
 
Reported: 2019-10-31 20:49 UTC by Artyom Davidov
Modified: 2020-08-17 07:11 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (vsevolod)


Attachments
Patch for openblas support (775 bytes, patch)
2019-10-31 20:49 UTC, Artyom Davidov
no flags Details | Diff
patch for mail/rspamd-devel (2.52 KB, patch)
2019-11-05 06:44 UTC, Alexander Moisseev
no flags Details | Diff
Really disable OpenBLAS by default (2.48 KB, patch)
2019-11-06 16:19 UTC, Alexander Moisseev
no flags Details | Diff
Add ENABLE_BLAS CMake flag (752 bytes, patch)
2019-11-06 16:29 UTC, Alexander Moisseev
no flags Details | Diff
Update mail/rspamd-devel patch to current Rspamd version (2.48 KB, patch)
2019-11-20 06:32 UTC, Alexander Moisseev
no flags Details | Diff
Update mail/rspamd patch to current Rspamd version (2.18 KB, patch)
2019-11-20 06:35 UTC, Alexander Moisseev
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Artyom Davidov 2019-10-31 20:49:58 UTC
Created attachment 208748 [details]
Patch for openblas support

Hello,

This patch will bring optional OpenBLAS support for KANN in Rspamd.

It is disabled by default since additional testing should be performed on performance implications of using KANN with OpenBLAS in end-user environment.

This patch won't bump portrevision.
Comment 1 Alexander Moisseev 2019-11-05 06:44:17 UTC
Created attachment 208872 [details]
patch for mail/rspamd-devel

mail/rspamd-devel:
- Update to 2.2.a1.20191105
- Add OpenBLAS support for KANN
Comment 2 Alexander Moisseev 2019-11-06 16:19:34 UTC
Created attachment 208914 [details]
Really disable OpenBLAS by default
Comment 3 Alexander Moisseev 2019-11-06 16:29:17 UTC
Created attachment 208915 [details]
Add ENABLE_BLAS CMake flag

ENABLE_BLAS CMake flag is not implemented in Rspamd 2.1 yet. I propose adding it now just to not forget.
Comment 4 Artyom Davidov 2019-11-06 18:29:54 UTC
(In reply to Alexander Moisseev from comment #3)

I totally agree.

It'll be also great if Rspamd could log on startup some information about OpenBLAS library build options. ( https://github.com/xianyi/OpenBLAS/wiki/faq#buildoptions )
Right now it is hard to figure out what OpenBLAS core is being used if OpenBLAS was build with DYNAMIC_ARCH. Also this could be useful while debugging issues if they'll arise.
Comment 5 Alexander Moisseev 2019-11-20 06:32:17 UTC
Created attachment 209266 [details]
Update mail/rspamd-devel patch to current Rspamd version
Comment 6 Alexander Moisseev 2019-11-20 06:35:30 UTC
Created attachment 209268 [details]
Update mail/rspamd patch to current Rspamd version
Comment 7 commit-hook freebsd_committer 2019-11-23 22:04:43 UTC
A commit references this bug:

Author: vsevolod
Date: Sat Nov 23 22:04:26 UTC 2019
New revision: 518277
URL: https://svnweb.freebsd.org/changeset/ports/518277

Log:
  - Update to 2.2
  - Add OpenBLAS support (optional) [2]

  PR:		241626
  Submitted by:	Alexander Moisseev <moiseev at mezonplus.ru> [1], [2]
  Reported by:	Artyom Davidov <ard_1 at mail.ru> [2]

Changes:
  head/mail/rspamd/Makefile
  head/mail/rspamd/distinfo
  head/mail/rspamd/pkg-plist
Comment 8 Vsevolod Stakhov freebsd_committer 2019-11-23 22:04:56 UTC
*** Bug 242092 has been marked as a duplicate of this bug. ***
Comment 9 commit-hook freebsd_committer 2019-11-23 22:06:45 UTC
A commit references this bug:

Author: vsevolod
Date: Sat Nov 23 22:06:23 UTC 2019
New revision: 518278
URL: https://svnweb.freebsd.org/changeset/ports/518278

Log:
  - Update to 2.3-a1
  - Add OpenBLAS support (optional) [2]

  PR:           241626
  Submitted by: Alexander Moisseev <moiseev at mezonplus.ru> [1], [2]
  Reported by:  Artyom Davidov <ard_1 at mail.ru> [2]

Changes:
  head/mail/rspamd-devel/Makefile
  head/mail/rspamd-devel/distinfo
  head/mail/rspamd-devel/pkg-plist
Comment 10 Mark Linimon freebsd_committer freebsd_triage 2020-08-17 07:11:39 UTC
Committed Nov 23 22:04:26 UTC 2019 as r518277.