Bug 241668 - [NEW PORT] x11/mere-utils: Utility bundle for mere system interface
Summary: [NEW PORT] x11/mere-utils: Utility bundle for mere system interface
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias C. Berner
URL:
Keywords: feature, needs-qa
: 241667 (view as bug list)
Depends on:
Blocks: 241839
  Show dependency treegraph
 
Reported: 2019-11-02 11:43 UTC by Bhuiyan Mohammad Iklash
Modified: 2019-11-09 21:14 UTC (History)
2 users (show)

See Also:


Attachments
x11/mere-utils: Utility bundle for mere system interface (2.18 KB, text/plain)
2019-11-02 11:43 UTC, Bhuiyan Mohammad Iklash
no flags Details
x11/mere-utils: Utility bundle for mere system interface (2.24 KB, text/plain)
2019-11-04 00:24 UTC, Bhuiyan Mohammad Iklash
no flags Details
x11/mere-utils: Utility bundle for mere system interface (655.26 KB, text/plain)
2019-11-04 09:55 UTC, Bhuiyan Mohammad Iklash
no flags Details
x11/mere-utils: Utility bundle for mere system interface (655.26 KB, text/plain)
2019-11-04 09:56 UTC, Bhuiyan Mohammad Iklash
no flags Details
x11/mere-utils: Utility bundle for mere system interface (2.20 KB, text/plain)
2019-11-09 19:50 UTC, Bhuiyan Mohammad Iklash
no flags Details
x11/mere-utils: Utility bundle for mere system interface (2.10 KB, text/plain)
2019-11-09 20:16 UTC, Bhuiyan Mohammad Iklash
no flags Details
x11/mere-utils: Utility bundle for mere system interface (2.36 KB, text/plain)
2019-11-09 20:44 UTC, Bhuiyan Mohammad Iklash
no flags Details
x11/mere-utils: Utility bundle for mere system interface (2.51 KB, text/plain)
2019-11-09 21:05 UTC, Bhuiyan Mohammad Iklash
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bhuiyan Mohammad Iklash 2019-11-02 11:43:47 UTC
Created attachment 208792 [details]
x11/mere-utils: Utility bundle for mere system interface

This port is a utility library, which is required by some of the application of mere system interface.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2019-11-03 14:23:55 UTC
*** Bug 241667 has been marked as a duplicate of this bug. ***
Comment 2 Bhuiyan Mohammad Iklash 2019-11-04 00:24:25 UTC
Created attachment 208836 [details]
x11/mere-utils: Utility bundle for mere system interface

Previous .shar was wrong. So attached the correct one and open the issue.
Comment 3 Bhuiyan Mohammad Iklash 2019-11-04 02:10:31 UTC
I had attached wrong .shar previously, now corrected and re-open the issue for consideration.
Comment 4 Bhuiyan Mohammad Iklash 2019-11-04 09:55:24 UTC
Created attachment 208842 [details]
x11/mere-utils: Utility bundle for mere system interface
Comment 5 Bhuiyan Mohammad Iklash 2019-11-04 09:56:50 UTC
Created attachment 208843 [details]
x11/mere-utils: Utility bundle for mere system interface

Newer .shar
Comment 6 Bhuiyan Mohammad Iklash 2019-11-04 09:59:37 UTC
Comment on attachment 208842 [details]
x11/mere-utils: Utility bundle for mere system interface

old one
Comment 7 Tobias C. Berner freebsd_committer 2019-11-09 19:28:20 UTC
Moin moin 

It looks like you included more and less than you wanted -- the port is missing, but the WRKDIR is there :)

mfg Tobias
Comment 8 Bhuiyan Mohammad Iklash 2019-11-09 19:50:03 UTC
Created attachment 209010 [details]
x11/mere-utils: Utility bundle for mere system interface

Same, :( previous bundle was fully wrong! Hope this is fine.
Comment 9 Tobias C. Berner freebsd_committer 2019-11-09 19:54:21 UTC
Moin moin

The shar looks better now. 
Could you also apply the changes from the other PR here, please?
Drop GH_TAGNAME, GH_PROJECT and set DISTVERSIONPREFIX. Also use tabs not spaces after the '='.

mfg Tobias
Comment 10 Tobias C. Berner freebsd_committer 2019-11-09 19:55:17 UTC
Also, USE_XORG without USES=xorg is no longer supported soon, so you need to add it :)
Comment 11 Tobias C. Berner freebsd_committer 2019-11-09 19:56:30 UTC
Also, there is no need to set PORTREVISION -- drop that in both.
Comment 12 Tobias C. Berner freebsd_committer 2019-11-09 19:59:11 UTC
bin/mere-utils
bin/mere-utils-tests

seem to be missing from the plist.
Comment 13 Bhuiyan Mohammad Iklash 2019-11-09 20:16:15 UTC
Created attachment 209013 [details]
x11/mere-utils: Utility bundle for mere system interface

modified accordingly.
Comment 14 Tobias C. Berner freebsd_committer 2019-11-09 20:27:29 UTC
The port looks fine now. 

Coud you extend the pkg-descr a bit? It's not clear what the port is for :)
Comment 15 Bhuiyan Mohammad Iklash 2019-11-09 20:44:07 UTC
Created attachment 209017 [details]
x11/mere-utils: Utility bundle for mere system interface

Updated pkg-descr file to describe it more.
Comment 16 Tobias C. Berner freebsd_committer 2019-11-09 20:48:08 UTC
It still not quite clears up the question "what is 'mere'" :) but getting better.
Comment 17 Bhuiyan Mohammad Iklash 2019-11-09 21:05:31 UTC
Created attachment 209021 [details]
x11/mere-utils: Utility bundle for mere system interface

Describing about a bit on "mere" - a system interface mainly develop for FreeBSD users who is using it as his/her primary desktop operation system like me.
Comment 18 commit-hook freebsd_committer 2019-11-09 21:13:51 UTC
A commit references this bug:

Author: tcberner
Date: Sat Nov  9 21:12:59 UTC 2019
New revision: 517147
URL: https://svnweb.freebsd.org/changeset/ports/517147

Log:
  New port --  x11/mere-utils: Utility bundle for mere system interface

  Utility bundle for mere system interface

  Mere system interface utility contains all the helper functions required for
  applications of mere system interface.

  Currently it has following helpers and will grow over time:
  - AppUtils
  - FileUtils
  - i18nUtils
  - StringUtils
  - ProcessUtils
  - SignalUtils
  etc...

  Note:
  mere system interface is an interface to your system, it will work like your
  traditional desktop environment with easy to modify and configurable.

  WWW: http://utils.merelab.io/

  PR:		241668
  Submitted by:	Bhuiyan Mohammad Iklash <bhuiyan.mohammad.iklash@gmail.com>

Changes:
  head/x11/Makefile
  head/x11/mere-utils/
  head/x11/mere-utils/Makefile
  head/x11/mere-utils/distinfo
  head/x11/mere-utils/pkg-descr
  head/x11/mere-utils/pkg-plist
Comment 19 Tobias C. Berner freebsd_committer 2019-11-09 21:14:38 UTC
Committed with minor changes.