Bug 241702 - ports-mgmt/synth: WANT_OPENLDAP_SASL not considered
Summary: ports-mgmt/synth: WANT_OPENLDAP_SASL not considered
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Eric Turgeon
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-04 08:23 UTC by Matthias Pfaller
Modified: 2019-11-06 09:46 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ericbsd)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Pfaller 2019-11-04 08:23:43 UTC
I have set WANT_OPENLDAP_SASL in /etc/make.conf

When I build net/samba410 or net/nss-pam-ldapd without synth and without having openldap-sasl-client installed both ports will use openldap-sasl-client. 

When doing this using synth, they will build against openldap-client. 

This in turn will result in openldap-sasl-server getting uninstalled...

Is this a bug or a configuration error on my side?
Comment 1 Matthias Pfaller 2019-11-06 09:45:44 UTC
It looks like synth just ignores /etc/make.conf.

After copying /etc/make.conf to /usr/local/etc/synth/LiveSystem-make.conf net/samba410 net/nss-pam-ldapd are built against openldap-sasl-client.

Sorry for the noise.