Bug 241714 - /usr/bin/diff --tabsize dies with SIGSEGV
Summary: /usr/bin/diff --tabsize dies with SIGSEGV
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 12.1-RELEASE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-05 00:23 UTC by rlwestlund
Modified: 2019-11-05 00:40 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rlwestlund 2019-11-05 00:23:06 UTC
On the three systems I've tried, /usr/bin/diff with --tabsize dies with SIGSEGV, regardless of any other options or arguments.

I'm observing the crash on FreeBSD 12.1-RELEASE.
uname -a: FreeBSD coppermind 12.0-RELEASE-p10 FreeBSD 12.0-RELEASE-p10 GENERIC  amd64
freebsd-version -kur:
12.1-RELEASE
12.1-RELEASE
12.1-RELEASE

Outside of --tabsize, diff works normally.

The synopsis in diff(1) indicates that the option is a standalone. Later in the man page it's shown as '-tabsize' (as opposed to --tabsize), and said to take an argument (which makes sense); however I think the single dash is a typo because when I run diff -tabsize 3 file1 file2, I get "diff: invalid option -- z".

I've also tested this on two 12.0-RELEASE-p10 systems (DO droplets), and seen the crash on them as well. I updated the userland of those systems to 12.0-RELEASE-p11 and the same thing happened. The DO droplets are also amd64 machines with GENERIC kernel.
Comment 1 rlwestlund 2019-11-05 00:36:32 UTC
I'm trying to attach the core dump, but the server is telling me 413 Request Entity Too Large. What should I do about this? I assume the core dump is important.
Comment 2 rlwestlund 2019-11-05 00:40:20 UTC
Sorry to post again, but the uname -a output I posted in the first comment was wrong. It says:

FreeBSD coppermind 12.1-RELEASE FreeBSD 12.1-RELEASE r354233 GENERIC  amd64

The 12.0-RELEASE-p10 output I posted was copy-pasted from having the issue on 12.0-RELEASE-p10 first, which was what prompted me to upgrade to 12.1-RELEASE to see if that fixed it. (I had saved the draft of my post from before then in a text file to reboot, and pasted it back in, and forgot to edit that part).