Bug 241720 - www/squid: 4.8_1 delay pools not working
Summary: www/squid: 4.8_1 delay pools not working
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
: 241722 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-11-05 03:35 UTC by Jenny Cabrera Varona
Modified: 2019-11-22 10:48 UTC (History)
1 user (show)

See Also:
koobs: maintainer-feedback+


Attachments
squid.conf file used (6.02 KB, text/plain)
2019-11-05 17:10 UTC, Jenny Cabrera Varona
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jenny Cabrera Varona 2019-11-05 03:35:23 UTC

    
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-11-05 03:55:25 UTC
*** Bug 241722 has been marked as a duplicate of this bug. ***
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2019-11-05 03:57:54 UTC
Thank you for the report Jenny.

Can you please provide additional information including:


- Exact FreeBSD version (uname -a output)
- Squid configuration (sanitized where necessary)
- Information about the method of installation (ports, packages?)
- If via ports, what port OPTIONS the port was built with/without
- Whether is is a regression from a previous version, and if so, what version worked with delay pools prior to the upgrade
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2019-11-05 03:58:36 UTC
Please include squid configuration and any other long bodies of text as attachments, rather than pasted in comments
Comment 4 Jenny Cabrera Varona 2019-11-05 16:33:36 UTC
(In reply to Kubilay Kocak from comment #2)
Hi Kubilay

Version: FreeBSD 12.0-Release p11 (right now)

Squid 4.8_1 Config: Simple squid.conf with the most simple and functional delay_pools, tested on squid 3.5.x without problem, no debug error using squid -X, no error on cache.log or access.log

Installation Method tested were both (ports and packages), packages come with delay_pools enabled as default, and manually enabled on port installation

Using ports the options was the default options including delay_pools

Upgrade was from squid 4.7_1 with the same delay_pools problem, as i said before delay_pools just work fine for me using squid 3.5.x versions

if you also still needing my actual squid.conf i will attach the file on next message

thanks for your quick reply Kubilay
Comment 5 Jenny Cabrera Varona 2019-11-05 17:10:28 UTC
Created attachment 208886 [details]
squid.conf file used

the squid.conf used on 4.7_1 and 4.8_1 with delay_pools error and working fine on squid 3.5.23
Comment 6 timp87 2019-11-12 14:37:26 UTC
Hi, Jenny!
This might sound weird, but have you tried this functionality with the same config and squid version on any kind of linux?
I'm just wondering if it's freebsd-specific or squid4-related in general.
Comment 7 Jenny Cabrera Varona 2019-11-13 19:44:16 UTC
(In reply to timp87 from comment #6)

i have a friend who test this following simple lines on Arch with squid-4.8 and delay_pools doesn't work, just like FreeBSD, same results

##################
acl localnet src 172.17.110.224/27
delay_pools 1
delay_class 1 2
delay_parameters 1 none 8000/8000
delay_initial_bucket_level 50
delay_access 1 allow localnet
delay_access 1 deny all
##################

another friend test on Debian Buster and squid-4.8 too and he said everything it's fine with delay_pools
Comment 8 timp87 2019-11-14 09:05:25 UTC
(In reply to Jenny Cabrera Varona from comment #7)

Please, take a look at squid's mailling lists:
http://squid-web-proxy-cache.1019090.n4.nabble.com/Delay-pools-in-squid4-not-working-with-https-td4685837.html

Is it similar to your problem?

It also may tell you why delay_pool in some configurations works and does not in others.
Comment 9 Jenny Cabrera Varona 2019-11-14 17:30:00 UTC
(In reply to timp87 from comment #8)

then i just have to wait for new releases with this bug "peering support for SslBump" fixed or test with non official and non stable production version or use full sslbump and not splice/tunneling the connection ?
Comment 10 timp87 2019-11-15 08:44:55 UTC
(In reply to Jenny Cabrera Varona from comment #9)
I just wanted to show you a similar non-fixed problem and get a confirmation from you that it is your case. It's actually up to you what to do in this case since this problem will be not freebsd-specific.
Comment 11 Jenny Cabrera Varona 2019-11-15 14:05:43 UTC
(In reply to timp87 from comment #10)

yes yu're right thanks so much by your support, now we can close the report.