Bug 241726 - Fails to build: [CodeGen/AsmPrinter/CodeViewDebug.o] Error code 254
Summary: Fails to build: [CodeGen/AsmPrinter/CodeViewDebug.o] Error code 254
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: arm (show other bugs)
Version: 12.0-STABLE
Hardware: arm64 Any
: --- Affects Only Me
Assignee: freebsd-toolchain mailing list
URL: https://www.hirlimann.net/Ludovic/Fre...
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2019-11-05 07:58 UTC by Ludovic
Modified: 2019-11-06 06:44 UTC (History)
3 users (show)

See Also:
koobs: mfc-stable12?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ludovic 2019-11-05 07:58:48 UTC
c++  -O2 -pipe -I/usr/obj/usr/src/arm64.aarch64/tmp/obj-tools/lib/clang/libllvm -I/usr/src/contrib/llvm/lib/Target/AArch64 -I/usr/src/contrib/llvm/lib/Target/ARM -I/usr/src/lib/clang/include -I/usr/src/contrib/llvm/include -DLLVM_BUILD_GLOBAL_ISEL -D__STDC_LIMIT_MACROS -D__STDC_CONSTANT_MACROS -DNDEBUG -DLLVM_DEFAULT_TARGET_TRIPLE=\"aarch64-unknown-freebsd12.0\" -DLLVM_HOST_TRIPLE=\"aarch64-unknown-freebsd12.0\" -DDEFAULT_SYSROOT=\"/usr/obj/usr/src/arm64.aarch64/tmp\" -DLLVM_TARGET_ENABLE_AARCH64 -DLLVM_TARGET_ENABLE_ARM -DLLVM_NATIVE_ASMPARSER=LLVMInitializeAArch64AsmParser -DLLVM_NATIVE_ASMPRINTER=LLVMInitializeAArch64AsmPrinter -DLLVM_NATIVE_DISASSEMBLER=LLVMInitializeAArch64Disassembler -DLLVM_NATIVE_TARGET=LLVMInitializeAArch64Target -DLLVM_NATIVE_TARGETINFO=LLVMInitializeAArch64TargetInfo -DLLVM_NATIVE_TARGETMC=LLVMInitializeAArch64TargetMC -ffunction-sections -fdata-sections -gline-tables-only -MD -MF.depend.CodeGen_AsmPrinter_DIEHash.o -MTCodeGen/AsmPrinter/DIEHash.o -Qunused-arguments -I/usr/obj/usr/src/arm64.aarch64/tmp/legacy/usr/include  -std=c++11 -fno-exceptions -fno-rtti -gline-tables-only -stdlib=libc++ -Wno-c++11-extensions  -c /usr/src/contrib/llvm/lib/CodeGen/AsmPrinter/DIEHash.cpp -o CodeGen/AsmPrinter/DIEHash.o
--- CodeGen/AsmPrinter/CodeViewDebug.o ---
c++: error: unable to execute command: Killed
c++: error: clang frontend command failed due to signal (use -v to see invocation)
FreeBSD clang version 8.0.1 (tags/RELEASE_801/final 366581) (based on LLVM 8.0.1)
Target: aarch64-unknown-freebsd12.0
Thread model: posix
InstalledDir: /usr/bin
c++: note: diagnostic msg: PLEASE submit a bug report to https://bugs.freebsd.org/submit/ and include the crash backtrace, preprocessed source, and associated run script.
c++: note: diagnostic msg: 
********************

PLEASE ATTACH THE FOLLOWING FILES TO THE BUG REPORT:
Preprocessed source(s) and associated run script(s) are located at:
c++: note: diagnostic msg: /tmp/CodeViewDebug-5e192c.cpp
c++: note: diagnostic msg: /tmp/CodeViewDebug-5e192c.sh
c++: note: diagnostic msg: 

********************
*** [CodeGen/AsmPrinter/CodeViewDebug.o] Error code 254
Comment 1 Ludovic 2019-11-05 08:04:13 UTC
(In reply to Ludovic from comment #0)

The tar.gz was too big to be attached in bugzilla. Uploaded the file at https://www.hirlimann.net/Ludovic/FreeBSD/241726.tar.gz
Comment 2 mikael.urankar 2019-11-05 08:22:19 UTC
It looks similar to bug #239186 bug #219473 bug #230402
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2019-11-06 02:00:39 UTC
@toolchain If these bugs are indeed duplicates, please close them accordingly, with the earliest issue being the one leftover, or the issue with the most information/analysis
Comment 4 Dimitry Andric freebsd_committer 2019-11-06 06:44:44 UTC
Yes, this is almost certainly an out-of-memory crash.  Check dmesg for "out of swap errors", add more RAM and/or swap, lower your -j level or lower your optimization level.  If you are certain this is not an OOM issue, please reopen.