Bug 241769 - Update sysutils/sanoid, sysutils/sanoid-devel ports to current versions
Summary: Update sysutils/sanoid, sysutils/sanoid-devel ports to current versions
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dan Langille
URL:
Keywords:
: 241770 241771 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-11-07 00:35 UTC by hartzell
Modified: 2019-11-21 18:05 UTC (History)
1 user (show)

See Also:


Attachments
diffs to update sanoid and sanoid-devel to current versions (2.07 KB, patch)
2019-11-07 00:35 UTC, hartzell
no flags Details | Diff
diff to update sanoid and sanoid-devel (1.67 KB, patch)
2019-11-21 17:20 UTC, hartzell
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description hartzell 2019-11-07 00:35:47 UTC
Created attachment 208927 [details]
diffs to update sanoid and sanoid-devel to current versions

The attached patch updates the sanoid port to v2.0.3 and the sanoid-devel port to commit 45d0898.

I'm the maintainer, but I'm new at this, for what it's worth.  Feedback encouraged.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2019-11-07 01:33:18 UTC
*** Bug 241770 has been marked as a duplicate of this bug. ***
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2019-11-07 01:33:53 UTC
*** Bug 241771 has been marked as a duplicate of this bug. ***
Comment 3 Dan Langille freebsd_committer 2019-11-21 15:49:31 UTC
I just composed a patch for 2.0.3 and found this PR when composing my own.
Comment 4 Dan Langille freebsd_committer 2019-11-21 16:01:25 UTC
The patch files to apply cleanly. I can see what you want to do.

I suspect it might not have been created correctly.

This should work correctly:

cd /usr/ports

svn di sysutils/sanoid-devel sysutils/sanoid > /tmp/patch-sanoid

Then attach the file to the PR

If you still have the files sitting around and you'd like to try again, please do so.

Otherwise, I have enough to do this commit.
Comment 5 Dan Langille freebsd_committer 2019-11-21 16:01:44 UTC
(In reply to Dan Langille from comment #4)

*patch fails to apply cleanly...
Comment 6 hartzell 2019-11-21 17:20:02 UTC
Created attachment 209323 [details]
diff to update sanoid and sanoid-devel

Second try at at this patch.  It applies cleanly for me:

```
hartzell@foo:/usr/ports % sudo patch -C < ~/tmp/sanoid.patch
Password:
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|--- sysutils/sanoid-devel/Makefile
|+++ sysutils/sanoid-devel/Makefile
--------------------------
Patching file sysutils/sanoid-devel/Makefile using Plan A...
Hunk #1 succeeded at 1 with fuzz 1.
Hunk #2 succeeded at 22.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|--- sysutils/sanoid-devel/distinfo
|+++ sysutils/sanoid-devel/distinfo
--------------------------
Patching file sysutils/sanoid-devel/distinfo using Plan A...
Hunk #1 succeeded at 1.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|--- sysutils/sanoid/Makefile
|+++ sysutils/sanoid/Makefile
--------------------------
Patching file sysutils/sanoid/Makefile using Plan A...
Hunk #1 succeeded at 2.
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|--- sysutils/sanoid/distinfo
|+++ sysutils/sanoid/distinfo
--------------------------
Patching file sysutils/sanoid/distinfo using Plan A...
Hunk #1 succeeded at 1.
done
hartzell@foo:/usr/ports %
```
Comment 7 Dan Langille freebsd_committer 2019-11-21 17:35:48 UTC
That applies cleanly here.
Comment 8 hartzell 2019-11-21 17:55:32 UTC
excellent!
Comment 9 commit-hook freebsd_committer 2019-11-21 18:04:32 UTC
A commit references this bug:

Author: dvl
Date: Thu Nov 21 18:04:02 UTC 2019
New revision: 518105
URL: https://svnweb.freebsd.org/changeset/ports/518105

Log:
  Update to latest versions

  PR:		241769
  Submitted by:	hartzell@alerce.com

Changes:
  head/sysutils/sanoid/Makefile
  head/sysutils/sanoid/distinfo
  head/sysutils/sanoid-devel/Makefile
  head/sysutils/sanoid-devel/distinfo
Comment 10 Dan Langille freebsd_committer 2019-11-21 18:05:39 UTC
Thank you.  Much appreciated. :)