Bug 241823 - deskutils/nextcloudclient: Rewriting keyring file every few seconds
Summary: deskutils/nextcloudclient: Rewriting keyring file every few seconds
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Michael Reifenberger
URL: https://reviews.freebsd.org/D22620
Keywords: needs-patch
Depends on:
Blocks:
 
Reported: 2019-11-09 13:55 UTC by Guido Falsi
Modified: 2019-12-01 17:12 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (mr)


Attachments
workaround (1.06 KB, patch)
2019-11-15 15:31 UTC, Guido Falsi
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Falsi freebsd_committer 2019-11-09 13:55:31 UTC
Hi,

I'm creating this bug report to link here a bug report I filed upstream and track progress.

the nextcloud desktop client is performing writes to the keyring file very few seconds. Every time it contacts the server to check for changes.

It looks like this is a regression introduced in version 2.6.1.

I have isolated the upstream commit introducing this and a single code line that can be commented out to stop this behaviour. The details are in the github issue here:

https://github.com/nextcloud/desktop/issues/1592

but simply commenting out that line is not a proper solution.
Comment 1 Guido Falsi freebsd_committer 2019-11-15 15:31:23 UTC
Created attachment 209166 [details]
workaround

I'm attaching a very simple patch I'm using as a workaround.

This patch makes the unwanted writes to the key ring stop.

It most probably has collateral effects on the remote wipe functionlaity.
Comment 2 Guido Falsi freebsd_committer 2019-12-01 14:04:49 UTC
Comment on attachment 209166 [details]
workaround

Upstream provided a fix for this. [1]

I created a code review on phabricator to import it.


[1] https://github.com/nextcloud/desktop/commit/dcc84d35085d790a53b472d1edba663832af238a
Comment 3 commit-hook freebsd_committer 2019-12-01 15:48:00 UTC
A commit references this bug:

Author: mr
Date: Sun Dec  1 15:47:02 UTC 2019
New revision: 518779
URL: https://svnweb.freebsd.org/changeset/ports/518779

Log:
  Add patch to fix problem with keyring rewriting.

  PR:		241823
  Submitted by:	Guido Falsi

Changes:
  head/deskutils/nextcloudclient/Makefile
  head/deskutils/nextcloudclient/files/patch-fix_remote_wipe_keychain_storage
Comment 4 Guido Falsi freebsd_committer 2019-12-01 17:12:39 UTC
Thanks!