Bug 241863 - cad/librecad: fix build on LLVM-architectures
Summary: cad/librecad: fix build on LLVM-architectures
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jason E. Hale
URL:
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2019-11-10 16:38 UTC by Piotr Kubaj
Modified: 2019-11-29 14:31 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (jhale)


Attachments
patch (612 bytes, patch)
2019-11-10 16:38 UTC, Piotr Kubaj
pkubaj: maintainer-approval? (jhale)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2019-11-10 16:38:41 UTC
Created attachment 209039 [details]
patch

Last GCC fix broke Clang, the issue is already reported here https://github.com/LibreCAD/LibreCAD/issues/1130

Apply the upstream patch for GCC only on GCC architectures.
Comment 1 Automation User 2019-11-25 04:51:46 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/98216890
Comment 2 commit-hook freebsd_committer 2019-11-29 14:31:28 UTC
A commit references this bug:

Author: pkubaj
Date: Fri Nov 29 14:30:43 UTC 2019
New revision: 518655
URL: https://svnweb.freebsd.org/changeset/ports/518655

Log:
  cad/librecad: fix build on LLVM architectures

  Last GCC fix broke Clang, the issue is already reported here https://github.com/LibreCAD/LibreCAD/issues/1130

  Apply the upstream patch for GCC only on GCC architectures.

  PR:		241863
  Approved by:	jhale (maintainer timeout), mentors (implicit approval)

Changes:
  head/cad/librecad/Makefile