Bug 241893 - [NEW PORT] x11-toolkits/py-wxPython40: GUI toolkit for the Python programming language
Summary: [NEW PORT] x11-toolkits/py-wxPython40: GUI toolkit for the Python programming...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Loïc Bartoletti
URL: http://www.wxpython.org
Keywords:
Depends on:
Blocks: 241892
  Show dependency treegraph
 
Reported: 2019-11-11 20:16 UTC by Loïc Bartoletti
Modified: 2020-02-29 18:28 UTC (History)
1 user (show)

See Also:
antoine: exp-run+


Attachments
py-wxPython40 4.0.6 (9.04 KB, patch)
2019-11-11 20:16 UTC, Loïc Bartoletti
no flags Details | Diff
wxPython 4.0.7, fix unicode for wxgtk30 use wxPython40 for python and wxgtk30 and fix some ports tested on 12amd64 (11.42 KB, patch)
2020-01-24 14:51 UTC, Loïc Bartoletti
no flags Details | Diff
wxPython 4.0.7, fix unicode for wxgtk30 use wxPython40 for python and wxgtk30 and fix some ports tested on 12amd64 (copies as adds) (15.94 KB, patch)
2020-01-27 05:56 UTC, Loïc Bartoletti
no flags Details | Diff
wxPython 4.0.7, fix unicode for wxgtk30 use wxPython40 for python and wxgtk30 and fix some ports tested on 12amd64 (copies as adds) (12.30 KB, patch)
2020-02-04 06:07 UTC, Loïc Bartoletti
no flags Details | Diff
wxPython40 for exp-run (11.19 KB, patch)
2020-02-04 20:27 UTC, Loïc Bartoletti
no flags Details | Diff
wxPython40 for exp-run (11.66 KB, patch)
2020-02-09 17:27 UTC, Loïc Bartoletti
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Loïc Bartoletti freebsd_committer 2019-11-11 20:16:15 UTC
Created attachment 209070 [details]
py-wxPython40 4.0.6

x11-toolkits/py-wxPython40: GUI toolkit for the Python programming language

 * New port
 * Patches to build with llvm
 * Don't use gcc if wxWidgets is built with llvm

QA:

  * portlint: OK (1 unrevelant warning)
  * testport: OK (poudriere: 11, 12, 13, i386/amd64)
  * maketest: OK (demo tested, and used per databases/grass7)
Comment 1 Loïc Bartoletti freebsd_committer 2020-01-24 14:51:48 UTC
Created attachment 211012 [details]
wxPython 4.0.7, fix unicode for wxgtk30 use wxPython40 for python and wxgtk30 and fix some ports tested on 12amd64


Hi there 

I would like to ask for an exp-run to update (fix unicode) for x11-toolkits/wxgtk30 and the new port x11-toolkits/py-wxPython40. Since x11-toolkits/py-wxPython40 is the only wxPython to support py3 we want to use it for all ports which required wx python, so I also update Mk/bsd.wx.mk with x11-toolkits/py-wxPython40 for wxgtk30.

The patch is attached, and can also be found from the review https://reviews.freebsd.org/D21915:
https://reviews.freebsd.org/file/data/tg23u4touijdwistlxuk/PHID-FILE-tw2mvsjnymdbbj5xfzry/D21915.diff

Thanks.
Comment 2 Antoine Brodin freebsd_committer 2020-01-25 20:06:43 UTC
Can you regenerate your patch with --show-copies-as-adds ?
Comment 3 Loïc Bartoletti freebsd_committer 2020-01-27 05:56:04 UTC
Created attachment 211098 [details]
wxPython 4.0.7, fix unicode for wxgtk30 use wxPython40 for python and wxgtk30 and fix some ports tested on 12amd64 (copies as adds)
Comment 4 Loïc Bartoletti freebsd_committer 2020-01-27 05:56:36 UTC
(In reply to Antoine Brodin from comment #2)
Done, https://bz-attachments.freebsd.org/attachment.cgi?id=211098
Comment 5 Antoine Brodin freebsd_committer 2020-02-01 07:42:51 UTC
djvusmooth keeps using py-wxpython30, is this intended?
Comment 7 Antoine Brodin freebsd_committer 2020-02-01 09:51:37 UTC
Also,  can you check if comms/congruity and graphics/py-mayavi can't be switched to USE_WX=3.0+
Comment 8 Loïc Bartoletti freebsd_committer 2020-02-04 06:07:20 UTC
Created attachment 211336 [details]
wxPython 4.0.7, fix unicode for wxgtk30 use wxPython40 for python and wxgtk30 and fix some ports tested on 12amd64 (copies as adds)

- Update comms/congruity and graphics/py-mayavi to USE_WX=3.0+
- Replace LIB_DEPENDS to USE_WX for graphics/djvusmooth
Comment 9 Loïc Bartoletti freebsd_committer 2020-02-04 06:13:57 UTC
(In reply to Antoine Brodin from comment #6)

Mmm. It looks like that after my repo copy I force to remove useless patch ( patch-config.py ; patch-setup.py ; patch-src_gtk___gdi__wrap.cpp ; patch-src_gtk_propgrid__wrap.cpp ) and are not present in my diff.
Comment 10 Loïc Bartoletti freebsd_committer 2020-02-04 20:27:47 UTC
Created attachment 211356 [details]
wxPython40 for exp-run
Comment 12 Loïc Bartoletti freebsd_committer 2020-02-09 17:27:58 UTC
Created attachment 211515 [details]
wxPython40 for exp-run

antoine@ here the patch with kicad-devel support
Comment 13 Antoine Brodin freebsd_committer 2020-02-11 12:52:01 UTC
Exp-run looks fine.
Don't forget to bump PORTREVISION of ports that will now depend on py-wxPython40
Comment 14 Loïc Bartoletti freebsd_committer 2020-02-20 04:49:14 UTC
(In reply to Antoine Brodin from comment #13)
Thanks for the exp-run
Comment 15 commit-hook freebsd_committer 2020-02-29 18:25:14 UTC
A commit references this bug:

Author: lbartoletti
Date: Sat Feb 29 18:24:24 UTC 2020
New revision: 527449
URL: https://svnweb.freebsd.org/changeset/ports/527449

Log:
  x11-toolkits/py-wxPython40: GUI toolkit for the Python programming language

  py-wxPython40 aka Phoenix is a reborn of wxPython and in particular it allows to use wxWidgets with Python3.

    - Add x11-toolkits/py-wxPython40
    - Replace wxPython30 by wxPython40 when python wxWidgets is required
    - Fix cad/kicad and cad/kicad-devel to use wxPython40 "Phoenix"
    - Update comms/congruity, graphics/py-mayavi from wx 2.8 to 3.0
    - While I'm here fix portlint per emulators/playonbsd
    - Remove RUN_DEPENDS from USE_WX per graphics/djvusmooth
    - Bump portversion
    - Fix unicode on x11-toolkits/wxgtk30 and take Maintainer'ship

  PR:     241893
  Reviewed by:	koobs, tcberner
  Approved by:	tcberner (mentor)
  Differential Revision:  https://reviews.freebsd.org/D21915
  Exp-run by:     antoine

Changes:
  head/Mk/bsd.wx.mk
  head/audio/py-karaoke/Makefile
  head/cad/kicad/Makefile
  head/cad/kicad-devel/Makefile
  head/comms/congruity/Makefile
  head/comms/gnuradio/Makefile
  head/comms/quisk/Makefile
  head/databases/grass7/Makefile
  head/devel/py-robotframework-ride/Makefile
  head/emulators/playonbsd/Makefile
  head/games/pyfa/Makefile
  head/graphics/djvusmooth/Makefile
  head/graphics/py-mayavi/Makefile
  head/graphics/sk1/Makefile
  head/misc/pyobd/Makefile
  head/multimedia/photofilmstrip/Makefile
  head/x11-toolkits/Makefile
  head/x11-toolkits/py-SquareMap/Makefile
  head/x11-toolkits/py-wxPython40/
  head/x11-toolkits/py-wxPython40/Makefile
  head/x11-toolkits/py-wxPython40/distinfo
  head/x11-toolkits/py-wxPython40/files/patch-build.py
  head/x11-toolkits/py-wxPython40/files/patch-config.py
  head/x11-toolkits/py-wxPython40/files/patch-etg_propgridiface.py
  head/x11-toolkits/py-wxPython40/files/patch-setup.py
  head/x11-toolkits/py-wxPython40/files/patch-sip_cpp_sip__propgridwxPGPropArgCls.cpp
  head/x11-toolkits/py-wxPython40/files/patch-sip_gen_propgridiface.sip
  head/x11-toolkits/py-wxPython40/files/patch-src_gtk___gdi__wrap.cpp
  head/x11-toolkits/py-wxPython40/files/patch-src_gtk_propgrid__wrap.cpp
  head/x11-toolkits/wxgtk30/Makefile