Bug 241933 - [patch] sysutils/apache-mesos: Fix build for reversion of grpc dependency
Summary: [patch] sysutils/apache-mesos: Fix build for reversion of grpc dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Li-Wen Hsu
URL:
Keywords: buildisok, patch
Depends on:
Blocks:
 
Reported: 2019-11-13 02:44 UTC by James Wright
Modified: 2019-11-20 14:24 UTC (History)
3 users (show)

See Also:


Attachments
sysutils/apache-mesos diff (1.75 KB, patch)
2019-11-13 02:44 UTC, James Wright
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James Wright 2019-11-13 02:44:13 UTC
Created attachment 209121 [details]
sysutils/apache-mesos diff

Revert the patch added last week which fixed the breakage caused by the update of the grpc dependency from 1.22 -> 1.24, due to the grpc update then being reverted. https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=241594

Changes;
1) Remove the patch "patch-3rdparty_libprocess_include_process_grpc.hpp"
2) Bumped PORTREVISION
Comment 1 Automation User 2019-11-13 04:57:46 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/95514706
Comment 2 commit-hook freebsd_committer 2019-11-20 14:24:23 UTC
A commit references this bug:

Author: lwhsu
Date: Wed Nov 20 14:23:26 UTC 2019
New revision: 518021
URL: https://svnweb.freebsd.org/changeset/ports/518021

Log:
  Unbreak by reverting the patch for grpc 1.24, which was downgraded to 1.22 [1]

  PR:		241933, 241594 [1]
  Submitted by:	James Wright <james.wright@digital-chaos.com>

Changes:
  head/sysutils/apache-mesos/Makefile
  head/sysutils/apache-mesos/files/patch-3rdparty_libprocess_include_process_grpc.hpp