Bug 241991 - mail/py-pyspf: fix DNSLookup API for pydns
Summary: mail/py-pyspf: fix DNSLookup API for pydns
Status: Closed DUPLICATE of bug 241755
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-15 20:48 UTC by paul.le.gauret
Modified: 2019-11-18 18:24 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (sunpoet)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description paul.le.gauret 2019-11-15 20:48:29 UTC
Current version of pyspf sometimes generates errors while parsing SPF records. Issue is also known at Debian https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=940538

Debian maintainer has provided a patch (see below).

From: Scott Kitterman <scott@kitterman.com>
Date: Mon, 16 Sep 2019 23:18:58 -0400
Subject: fix DNSLookup API for pydns

---
 spf.py | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/spf.py b/spf.py
index 526e557..dec53ce 100755
--- a/spf.py
+++ b/spf.py
@@ -91,7 +91,7 @@ except ImportError:
         print('ipaddr module required: http://code.google.com/p/ipaddr-py/')
 
 
-def DNSLookup_pydns(name, qtype, tcpfallback=True, timeout=30):
+def DNSLookup_pydns(name, qtype, strict=True, timeout=20):
 
     try:
         req = DNS.DnsRequest(name, qtype=qtype, timeout=timeout)
Comment 1 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-11-18 18:24:17 UTC

*** This bug has been marked as a duplicate of bug 241755 ***