Bug 242040 - www/chromium Update from 78.0.3904.87 to 78.0.3904.92 broke discord
Summary: www/chromium Update from 78.0.3904.87 to 78.0.3904.92 broke discord
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-chromium mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-17 21:56 UTC by Alexander Vereeken
Modified: 2020-03-12 20:50 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (chromium)


Attachments
Image showing missing Discord icons, e.g. "pinned messages" (with red dot) (6.05 KB, image/png)
2020-03-03 10:57 UTC, DomF
no flags Details
Chrome dev console, "Elements" tab, showing "pinned messages" elements tree (195.54 KB, image/png)
2020-03-03 11:01 UTC, DomF
no flags Details
chromium's pkg dependencies as reported by "pkg info -d chromium" (1.02 KB, text/plain)
2020-03-03 11:05 UTC, DomF
no flags Details
runtime linkage of /usr/local/share/chromium/chrome as reported by ldd (7.58 KB, text/plain)
2020-03-03 11:07 UTC, DomF
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Vereeken 2019-11-17 21:56:35 UTC
The most symbols from discord dont get loaded anymore, this makes discord to 50% unusable, i can confirm this dont happens with older versions but cant confirm if its a freebsd issue.
Comment 1 DomF 2019-11-28 18:51:25 UTC
I'm also experiencing this with chromium-78.0.3904.108 on 12.1-RELEASE
Comment 2 DomF 2020-01-31 12:03:44 UTC
Still broken in chromium-79.0.3945.130
Comment 3 Alexander Vereeken 2020-02-11 20:32:02 UTC
Yep, can confirm it too and its only an issue on FreeBSD.
Comment 4 DomF 2020-03-03 10:57:22 UTC
Created attachment 212111 [details]
Image showing missing Discord icons, e.g. "pinned messages" (with red dot)

Added attachment demonstrating example of missing icons from top-right of Discord web page, including:

start voice call
start video call
pinned messages (where you can see the red dot)
add friends to DM
Comment 5 DomF 2020-03-03 11:01:55 UTC
Created attachment 212112 [details]
Chrome dev console, "Elements" tab, showing "pinned messages" elements tree

Added attachment of image snapshot of Chrome's dev console showing elements tree, focusing on missing/invisible "pinned messages" icon.

Corresponds to attachment 212111 [details].
Comment 6 DomF 2020-03-03 11:05:45 UTC
Created attachment 212113 [details]
chromium's pkg dependencies as reported by "pkg info -d chromium"

List of dependencies for chromium package, as reported by running "pkg info -d chromium".

Uploaded in case there's some conflict between (e.g.) gtk or png, etc.
Comment 7 DomF 2020-03-03 11:07:35 UTC
Created attachment 212114 [details]
runtime linkage of /usr/local/share/chromium/chrome as reported by ldd

1st-pass runtime linkage of /usr/local/share/chromium/chrome as reported by command "ldd /usr/local/share/chromium/chrome"

Uploaded in case an incorrect dynamic library is being chosen.
Comment 8 DomF 2020-03-03 11:11:04 UTC
I'm running FreeBSD 12.1-RELEASE-p2
Using an nVidia GTX 960 with driver version 390.87_3
xorg-7.7_3
Comment 9 Alexander Vereeken 2020-03-06 15:24:41 UTC
@DomF for me the issue is gone, can you confirm?
Comment 10 DomF 2020-03-09 09:28:55 UTC
Yes - all icons seem to be rendered now, even though I haven't updated any packages.

I see that there's a new <path> element inside the <svg> for the "pinned messages" icon corresponding to attachment 212112 [details].

So, bug on Discord's side?
Comment 11 Alexander Vereeken 2020-03-12 20:50:52 UTC
I close this as fixed for now :)