Bug 242065 - editors/py-pynvim: Update to 0.4.0
Summary: editors/py-pynvim: Update to 0.4.0
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jochen Neumeister
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2019-11-18 20:41 UTC by Thomas Merkel
Modified: 2019-11-21 08:18 UTC (History)
2 users (show)

See Also:


Attachments
patch for ports to update py-pynvim to version 0.4.0 (1.38 KB, patch)
2019-11-18 20:41 UTC, Thomas Merkel
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Merkel 2019-11-18 20:41:51 UTC
Created attachment 209236 [details]
patch for ports to update py-pynvim to version 0.4.0

Upstream provided a new version of py-pynvim. A patch has been attached to upgrade the port to 0.4.0.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-11-18 23:30:44 UTC
Comment on attachment 209236 [details]
patch for ports to update py-pynvim to version 0.4.0

^Triage: Reporter is MAINTAINER, set attachment maintainer-approval flag (to +) to signify maintainer approval
Comment 2 Jochen Neumeister freebsd_committer 2019-11-21 08:18:11 UTC
Heya Thomas,

are you sure about this?
> -RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}msgpack>=0.5.0:devel/py-msgpack@${PY_FLAVOR} \
>+RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}msgpack05>=0.5.0:devel/py-msgpack05@${PY_FLAVOR} \

This is an error on this change:

[00:00:03] Warning: (editors/py-pynvim): Error: editors/py-pynvim depends on nonexistent origin 'devel/py-msgpack05' (moved to devel/py-msgpack); Please contact maintainer of the port to fix this.