Bug 242065 - editors/py-pynvim: Update to 0.4.0
Summary: editors/py-pynvim: Update to 0.4.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias C. Berner
URL:
Keywords: needs-patch, needs-qa
: 244763 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-11-18 20:41 UTC by Thomas Merkel
Modified: 2020-03-14 08:39 UTC (History)
4 users (show)

See Also:


Attachments
patch for ports to update py-pynvim to version 0.4.0 (1.38 KB, patch)
2019-11-18 20:41 UTC, Thomas Merkel
koobs: maintainer-approval+
Details | Diff
patch for ports to update py-pynvim to version 0.4.0 include fix py-msgpack (883 bytes, patch)
2019-12-16 14:35 UTC, Thomas Merkel
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Merkel 2019-11-18 20:41:51 UTC
Created attachment 209236 [details]
patch for ports to update py-pynvim to version 0.4.0

Upstream provided a new version of py-pynvim. A patch has been attached to upgrade the port to 0.4.0.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-11-18 23:30:44 UTC
Comment on attachment 209236 [details]
patch for ports to update py-pynvim to version 0.4.0

^Triage: Reporter is MAINTAINER, set attachment maintainer-approval flag (to +) to signify maintainer approval
Comment 2 Jochen Neumeister freebsd_committer 2019-11-21 08:18:11 UTC
Heya Thomas,

are you sure about this?
> -RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}msgpack>=0.5.0:devel/py-msgpack@${PY_FLAVOR} \
>+RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}msgpack05>=0.5.0:devel/py-msgpack05@${PY_FLAVOR} \

This is an error on this change:

[00:00:03] Warning: (editors/py-pynvim): Error: editors/py-pynvim depends on nonexistent origin 'devel/py-msgpack05' (moved to devel/py-msgpack); Please contact maintainer of the port to fix this.
Comment 3 Thomas Merkel 2019-12-16 14:35:58 UTC
Created attachment 209995 [details]
patch for ports to update py-pynvim to version 0.4.0 include fix py-msgpack

It's totally true that the last patch wasn't valid based on the requirement for py-msgpack. I've attached a new patch without these changes!
Comment 4 Jochen Neumeister freebsd_committer 2019-12-20 11:39:47 UTC
(In reply to Thomas Merkel from comment #3)

Hi Thomas,

with this new patch, there is another error:

http://joneumbox.org/data/121i386-ports/2019-12-20_12h28m39s/logs/errors/py37-pynvim-0.4.0.log
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2019-12-20 11:56:38 UTC
(In reply to Jochen Neumeister from comment #4)

pytest-runner is unfortunately included as an unconditional setup_requires in the upstream code, when instead it should be conditional on setup.py invocation arguments including 'test' or similar.

See bug 241767 and ports r519582

I've created a PR upstream: https://github.com/neovim/pynvim/pull/418

You can either apply the patch from that PR, or patch out pytest-runner from setup_requires (making sure to add it as a TEST_DEPENDS in the port)
Comment 6 Goran Mekić 2020-03-13 00:26:10 UTC
*** Bug 244763 has been marked as a duplicate of this bug. ***
Comment 7 Tobias C. Berner freebsd_committer 2020-03-14 08:39:01 UTC
Committed. Thanks.
Comment 8 commit-hook freebsd_committer 2020-03-14 08:39:03 UTC
A commit references this bug:

Author: tcberner
Date: Sat Mar 14 08:38:33 UTC 2020
New revision: 528402
URL: https://svnweb.freebsd.org/changeset/ports/528402

Log:
  editors/py-pynvim: update to 0.4.0

  [1] https://github.com/neovim/pynvim/commit/f04853121de564ac03b981a984595ea33331ad3e

  PR:		242065
  Submitted by:	Thomas Merkel <tm@NetBSD.org>  (maintainer), koobs [1]

Changes:
  head/editors/py-pynvim/Makefile
  head/editors/py-pynvim/distinfo