Bug 242107 - audio/openal-soft: fix build on powerpc64 elfv2
Summary: audio/openal-soft: fix build on powerpc64 elfv2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias Kortkamp
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-20 13:05 UTC by Piotr Kubaj
Modified: 2019-11-25 14:38 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (tobik)


Attachments
patch (1.08 KB, patch)
2019-11-20 13:05 UTC, Piotr Kubaj
pkubaj: maintainer-approval? (tobik)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2019-11-20 13:05:45 UTC
Created attachment 209279 [details]
patch

powerpc64 doesn't have ld.gold. For some reason this doesn't cause a problem with GCC, but Clang doesn't like it:
cc: error: invalid linker name in argument '-fuse-ld=gold'

Use gold only if it exists.
Comment 1 commit-hook freebsd_committer 2019-11-20 13:57:20 UTC
A commit references this bug:

Author: tobik
Date: Wed Nov 20 13:56:36 UTC 2019
New revision: 518012
URL: https://svnweb.freebsd.org/changeset/ports/518012

Log:
  audio/openal-soft: Drop workaround from r492771

  The problem is no longer reproducible on the latest 12-STABLE snapshot
  and it breaks the build on powerpc64 elfv2.

  PR:		235603, 242107

Changes:
  head/audio/openal-soft/Makefile
Comment 2 Tobias Kortkamp freebsd_committer 2019-11-20 13:57:49 UTC
Is it ok after r518012?