Bug 242140 - dns/dnsdist: update to 1.4.0
Summary: dns/dnsdist: update to 1.4.0
Status: Closed DUPLICATE of bug 242125
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Carlos J. Puga Medina
URL: https://dnsdist.org/changelog.html#ch...
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-21 13:37 UTC by Leo Vandewoestijne
Modified: 2019-11-23 18:12 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (cpm)


Attachments
dnsdist upgrade to 1.4.0 (972 bytes, patch)
2019-11-21 13:37 UTC, Leo Vandewoestijne
no flags Details | Diff
dnsdist 1.4.0rc? multi-daemon (2.30 KB, patch)
2019-11-21 13:41 UTC, Leo Vandewoestijne
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Leo Vandewoestijne 2019-11-21 13:37:34 UTC
Created attachment 209317 [details]
dnsdist upgrade to 1.4.0

Hello,

Earlier today 1.4.0 was released.
The simple patch should work fine - I tested it with poudriere against 11.3 and 12.0 / both amd64.

The less simple patch is actually work from before, where I wished to run multiple daemons, and adjusted the rc script to allow me to do so.
However, I don't know if what I'm trying to accomplish is done right.
That patch was made agains a RC version, so should not be applied, but could be used as example.

Leo
Comment 1 Leo Vandewoestijne 2019-11-21 13:41:29 UTC
Created attachment 209318 [details]
dnsdist 1.4.0rc? multi-daemon

By these the multiple startup script patch example.
Reason I desire this was to keep rule-processing simple / separated / and make it faster (or better said: prevent going slow).
Comment 2 Carlos J. Puga Medina freebsd_committer 2019-11-23 18:12:03 UTC
Hi Leo,

I'm going to close this PR as a duplicate of pr242125, please would you mind sending your rc script there and discussing it with others?

*** This bug has been marked as a duplicate of bug 242125 ***