Bug 242177 - x11/linux-nvidia-libs: x11/nvidia-driver: 32-bit libraries and update to 440.59
Summary: x11/linux-nvidia-libs: x11/nvidia-driver: 32-bit libraries and update to 440.59
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Alexey Dokuchaev
URL:
Keywords:
: 243495 (view as bug list)
Depends on: 244311 244312
Blocks: 243272
  Show dependency treegraph
 
Reported: 2019-11-23 16:43 UTC by malavon
Modified: 2020-03-07 13:47 UTC (History)
11 users (show)

See Also:
mandree: maintainer-feedback+


Attachments
Update to 440.36 which adds 32-bit libraries by default (2.48 KB, patch)
2019-11-23 16:43 UTC, malavon
no flags Details | Diff
nvidia-driver 440.59 (3.32 KB, patch)
2020-02-08 22:11 UTC, Lorenzo Salvadore
no flags Details | Diff
nvidia-driver 440.59 with legacy ports fixed (4.36 KB, patch)
2020-02-15 14:56 UTC, Lorenzo Salvadore
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description malavon 2019-11-23 16:43:56 UTC
Created attachment 209363 [details]
Update to 440.36 which adds 32-bit libraries by default

Refer to https://devtalk.nvidia.com/default/topic/1065886/freebsd-solaris/request-include-32-bit-libraries-with-64-bit-drivers/

Because the 4x version no longer supports 32-bit, Nvidia has added the 32-bit libraries directly into their driver. This is definitely an improvement for Wine users.

Patch in attachment.
Comment 1 malavon 2019-11-27 21:39:35 UTC
In hindsight I forgot to both:
* check with the maintainer if it's ok to file this 
* check if this doesn't break any other ports

Consider it a quick and dirty fix until the maintainer has provided some kind of feedback.
Comment 2 Andrey Fesenko 2020-01-11 22:09:39 UTC
Thanks, after this patch game in wine work :)
Comment 3 Lorenzo Salvadore freebsd_committer 2020-02-08 22:11:44 UTC
Created attachment 211486 [details]
nvidia-driver 440.59

I update the proposed patch to 440.59.

It would be nice if we could try to avoid being to slow on this bug as, according to bug #243272 and to the experience described in comment #2, wine has indeed problems for nvidia users.

Thanks.
Comment 4 Lorenzo Salvadore freebsd_committer 2020-02-15 09:03:45 UTC
I just received a mail about the 32-bit libraries for nvidia drivers issue explained in this PR: other people are affected by this problem. I then change the severity to "Affects some people". Hopefully, this will help increasing the priority for this bug.
Comment 5 Alex S 2020-02-15 09:53:24 UTC
Before somebody actually decides to commit this patch on maintainer timeout: 1. that plist looks like it will break legacy (390, 340, 304) ports; 2. linux-nvidia-libs version should be bumped as well.
Comment 6 Lorenzo Salvadore freebsd_committer 2020-02-15 10:36:23 UTC
(In reply to Alex S from comment #5)

Thanks for noting the problem with the plists for nvidia driver legacy ports. I am testing a patch to fix it.
Comment 7 Lorenzo Salvadore freebsd_committer 2020-02-15 14:56:02 UTC
Created attachment 211672 [details]
nvidia-driver 440.59 with legacy ports fixed

Here is the new patch: I fixed the plist issues by creating a pkg-plist file for every nvidia-driver-* legacy port.

Tested successfully with poudriere on {11.3,12.1}-RELEASE {i386,amd64}.
Comment 8 Alexey Dokuchaev freebsd_committer 2020-02-21 18:52:35 UTC
(In reply to Lorenzo Salvadore from comment #7)
> I fixed the plist issues by creating a pkg-plist file for
> every nvidia-driver-* legacy port.
Which is what the port had beed trying to avoid since its inception. :-)

I don't have access to my original patch right now, but AFAIR it's doable without splitting the plist (this is not a call for action, I'm working on it now).
Comment 9 Alexey Dokuchaev freebsd_committer 2020-02-21 19:18:00 UTC
*** Bug 243495 has been marked as a duplicate of this bug. ***
Comment 10 Lorenzo Salvadore freebsd_committer 2020-02-21 19:19:01 UTC
Comment on attachment 211672 [details]
nvidia-driver 440.59 with legacy ports fixed

Thanks Alexey!
Don't forget to set the maintainer-feedback flag to + so that the PR does not appear to have a maintainer-timeout.

I mark my patch as obsolete for two reasons:
- you prefer to follow a different strategy;
- my patch is incomplete: I forgot to svn add the new pkg-plist files I created for the legacy ports (if, for any reason, you change your mind and want to use this strategy, I can upload the patch corrected if you want).
Comment 11 commit-hook freebsd_committer 2020-02-22 07:55:58 UTC
A commit references this bug:

Author: danfe
Date: Sat Feb 22 07:55:39 UTC 2020
New revision: 526742
URL: https://svnweb.freebsd.org/changeset/ports/526742

Log:
  Update nVidia drivers to their most recent versions.  The prominent change
  is that 32-bit libraries are now provided with the 4xx driver versions, so
  games should work under Wine.

  PR:	242177

Changes:
  head/x11/nvidia-driver/Makefile
  head/x11/nvidia-driver/distinfo
  head/x11/nvidia-driver/pkg-plist
  head/x11/nvidia-driver-340/Makefile
  head/x11/nvidia-driver-390/Makefile
Comment 12 Alex S 2020-02-22 08:53:51 UTC
This is your _third_ reminder that upgrading nvidia-driver without linux-nvidia-libs breaks Linux support:

% pkg info | grep nvidia
linux-nvidia-libs-440.44       NVidia graphics libraries and programs (Linux version)
nvidia-driver-440.59           NVidia graphics card binary drivers for hardware OpenGL rendering
nvidia-settings-440.26         Display Control Panel for X NVidia driver
nvidia-xconfig-440.26          Tool to manipulate X configuration files for the NVidia driver
% /compat/linux/bin/glxgears
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  32
  Current serial number in output stream:  33
Comment 13 Matthias Andree freebsd_committer 2020-02-22 12:23:20 UTC
Over to x11@ who maintain x11/linux-nvidia-libs
Comment 14 Matthias Andree freebsd_committer 2020-02-22 15:11:57 UTC
Comment on attachment 209363 [details]
Update to 440.36 which adds 32-bit libraries by default

marking the 440.36 patch obsolete
Comment 15 Matthias Andree freebsd_committer 2020-02-22 15:13:10 UTC
Back to Alexey, the blocking bugs have proper assignments.
Comment 16 Matthias Andree freebsd_committer 2020-03-07 13:47:11 UTC
------------------------------------------------------------------------
r527488 | danfe | 2020-03-01 04:38:47 +0100 (Sun, 01 Mar 2020) | 2 lines

Update to version 440.64.

------------------------------------------------------------------------