Bug 242230 - devel/vulkan-tools: Vulkan broken on Intel Broadwell?
Summary: devel/vulkan-tools: Vulkan broken on Intel Broadwell?
Status: Closed DUPLICATE of bug 235570
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-25 19:03 UTC by James Wright
Modified: 2019-11-28 04:22 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (greg)


Attachments
xorg log file (14.09 KB, text/plain)
2019-11-25 19:03 UTC, James Wright
no flags Details
dmesg output (9.93 KB, text/plain)
2019-11-25 19:04 UTC, James Wright
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Wright 2019-11-25 19:03:18 UTC
Created attachment 209417 [details]
xorg log file

Can't seem to get Vulkan Tools to work on my MacBookAir (see errors below). Is it supposed to work on Intel Broadwell CPUs with integrated gfx (i915)?

% uname -a
FreeBSD macbook 12.1-STABLE FreeBSD 12.1-STABLE r354662 MACBOOK  amd64

% pkg info -x vulkan       
vulkan-headers-1.1.108.0
vulkan-loader-1.1.108.0_1
vulkan-tools-1.1.108.0_1

**************************************************************

% vulkaninfo          
==========
VULKANINFO
==========

Vulkan Instance Version: 1.1.108

INTEL-MESA: warning: vulkan/anv_device.c:1215: FINISHME: Implement pop-free point clipping
/wrkdirs/usr/ports/devel/vulkan-tools/work/Vulkan-Tools-sdk-1.1.108.0/vulkaninfo/vulkaninfo.c:1128: failed with VK_ERROR_TOO_MANY_OBJECTS

**************************************************************

% vkcube
Assertion failed: (!err), function demo_create_device, file /wrkdirs/usr/ports/devel/vulkan-tools/work/Vulkan-Tools-sdk-1.1.108.0/cube/cube.c, line 3326.
zsh: abort (core dumped)  vkcube

**************************************************************

Can provide more output to help diagnose the issue if needed!
Comment 1 James Wright 2019-11-25 19:04:00 UTC
Created attachment 209418 [details]
dmesg output
Comment 2 Greg V 2019-11-26 23:56:38 UTC
Something's busted in mesa. Or in the kernel driver but that seems less likely considering the "FINISHME" warning from mesa :D

Try building a newer mesa from my port: https://github.com/myfreeweb/freebsd-ports-dank/tree/lite/graphics/mesa-dev Works fine for me on Kaby Lake and Haswell.
Comment 3 Jan Beich freebsd_committer 2019-11-27 02:09:08 UTC
Don't use Vulkan on Intel before bug 235570. It requires attachment 187401 [details], running as root and is not as stable.

*** This bug has been marked as a duplicate of bug 235570 ***
Comment 4 Jan Beich freebsd_committer 2019-11-27 02:28:20 UTC
(In reply to Jan Beich from comment #3)
> not as stable.

I915_USERPTR_UNSYNCHRONIZED is unstable in drm-kmod > v4.9 (since ports r487275) requiring bug 235570 (for ANV) and bug 236003 (for SNA). And regular userptr is still not supported.

https://github.com/FreeBSDDesktop/DEPRECATED-freebsd-base-graphics/issues/132
Comment 5 James Wright 2019-11-28 04:22:13 UTC
Fixed by upgrading to Mesa 19.0.8