Bug 242269 - www/qt5-webengine: build of 5.13.2 fails if older qt5-webengine installed (5.12.2)
Summary: www/qt5-webengine: build of 5.13.2 fails if older qt5-webengine installed (5....
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-27 18:27 UTC by John Hein
Modified: 2019-12-02 19:40 UTC (History)
1 user (show)

See Also:
tcberner: maintainer-feedback+


Attachments
build failure log (240.60 KB, application/x-xz)
2019-11-27 18:27 UTC, John Hein
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Hein 2019-11-27 18:27:08 UTC
Created attachment 209491 [details]
build failure log

If www/qt5-webengine 5.12.2 is installed, building 5.13.2 fails with multiple errors.

I suspect the fix is to get the build to look in ${WRKSRC} before ${LOCALBASE} for include files (-I options).

A workaround is to delete the old version of qt5-webengine that is currently installed in ${LOCALBASE}.  But this should be fixed to not require users to do that.

A build log showing the failure is attached.
Comment 1 Tobias C. Berner freebsd_committer 2019-11-27 19:11:05 UTC
This is a known error and documented in UPDATING.

The solution is to use a proper port-buildsystem  (read poudriere) with isolated builds or deinstall the port prior to building it. 


I close this as "work-as-intended" -- even though that is not satisfactory, obviously :)


mfg Tobias
Comment 2 John Hein 2019-12-02 19:39:17 UTC
(In reply to Tobias C. Berner from comment #1)
Thanks.  Sorry for not checking UPDATING.
Comment 3 Tobias C. Berner freebsd_committer 2019-12-02 19:40:23 UTC
No worries :)