Bug 242279 - emulators/qemu-utils: Doesn't build after switch to qemu 4.1
Summary: emulators/qemu-utils: Doesn't build after switch to qemu 4.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Alan Somers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-28 10:10 UTC by Mateusz Kwiatkowski
Modified: 2019-12-01 15:51 UTC (History)
0 users

See Also:
asomers: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz Kwiatkowski 2019-11-28 10:10:21 UTC
Seems that patch needs included in qemu-utils should be updated:

monster-1 qemu-utils # make install
===>  Patching for qemu-utils-4.1.1
===>  Applying extra patch /usr/ports/emulators/qemu-utils/files/patch-configure
2 out of 2 hunks failed--saving rejects to configure.rej
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/emulators/qemu-utils
*** Error code 1

Stop.
make: stopped in /usr/ports/emulators/qemu-utils
Comment 1 commit-hook freebsd_committer 2019-12-01 15:51:01 UTC
A commit references this bug:

Author: asomers
Date: Sun Dec  1 15:50:24 UTC 2019
New revision: 518780
URL: https://svnweb.freebsd.org/changeset/ports/518780

Log:
  emulators/qemu-utils: fix build after r518397

  PR:		242279
  Reported by:	pkg-fallout

Changes:
  head/emulators/qemu-utils/Makefile
  head/emulators/qemu-utils/files/patch-Makefile
  head/emulators/qemu-utils/files/patch-configure