Bug 242320 - www/web2ldap: Update to 1.5.68, Remove BROKEN
Summary: www/web2ldap: Update to 1.5.68, Remove BROKEN
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Palle Girgensohn
URL:
Keywords: needs-patch, needs-qa
Depends on: 242043
Blocks:
  Show dependency treegraph
 
Reported: 2019-11-30 10:09 UTC by geraud
Modified: 2020-05-01 08:30 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (girgen)


Attachments
patch (2.18 KB, patch)
2019-11-30 10:10 UTC, geraud
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description geraud 2019-11-30 10:09:50 UTC
Update to the latest version

Requires python 3.6+
Comment 1 geraud 2019-11-30 10:10:56 UTC
Created attachment 209548 [details]
patch
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-01-13 02:54:01 UTC
Upstream is now 1.5.45
Comment 3 daniel.engberg.lists 2020-04-30 21:33:26 UTC
Hi,

According to https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/flavors-auto-python.html you don't need to / shouldn't define compatible versions of Python.

Upstream is at 1.5.68

Does it build using Poudriere?

Best regards,
Daniel
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2020-05-01 03:03:13 UTC
(In reply to daniel.engberg.lists from comment #3)

To be precise, a ports job is only to 'declare' what versions of Python a package *supports*, not prescribe what version of Python the port should *use*.


Regarding:

-PORTVERSION=	1.3.16
+PORTVERSION=	1.5.18
...
-USES=		cpe python:2.7
+USES=		cpe python:3.6+

If 1.5.18 (now 1.5.68, see below) *only* supports 3.6+, then the change is correct and acceptable. Upstream setup.py currently specifies:

python_requires='>=3.6.*',

Also, upstream is now at version 1.5.68. This issue needs an updated patch.

While we're here, other review items:

- The package ships tests, please add TEST_DEPENDS and a (do-)test target to run them for QA.

- The package specifies console_scripts for command line scripts, so the port must be made concurrent safe (USE_PYTHON=concurrent)
Comment 5 daniel.engberg.lists 2020-05-01 08:30:58 UTC
(In reply to Kubilay Kocak from comment #4)
I apologize, I misinterpreted the handbook about USES.