Bug 242321 - [NEW PORT] audio/somafm-cli: Listen to SomaFM in your terminal
Summary: [NEW PORT] audio/somafm-cli: Listen to SomaFM in your terminal
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mateusz Piotrowski
URL: https://github.com/rockymadden/somafm...
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-30 11:38 UTC by Lewis Cook
Modified: 2019-12-01 11:16 UTC (History)
1 user (show)

See Also:


Attachments
somafm-cli port diff (2.62 KB, patch)
2019-11-30 11:38 UTC, Lewis Cook
no flags Details | Diff
somafm-cli port diff (2.64 KB, patch)
2019-11-30 11:56 UTC, Lewis Cook
no flags Details | Diff
somafm-cli port diff (2.69 KB, patch)
2019-11-30 13:50 UTC, Lewis Cook
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lewis Cook 2019-11-30 11:38:01 UTC
Created attachment 209549 [details]
somafm-cli port diff

Stream your favorite music channels from
somafm.com within a terminal using mpv.

WWW: https://github.com/rockymadden/somafm-cli

QA:
 * portlint: looks fine;
 * poudriere: package built, application works as intended.
Comment 1 Lewis Cook 2019-11-30 11:56:01 UTC
Created attachment 209551 [details]
somafm-cli port diff

* Didn't catch this till the last moment. Curl is needed to make the request to somafm to retrieve the channel names, so added that to RUN_DEPENDS.
Comment 2 Mateusz Piotrowski freebsd_committer 2019-11-30 13:21:23 UTC
Hi, thanks for the patch.

Could you also add USES=shebangfix to fix the shebang line in the script?
Comment 3 Lewis Cook 2019-11-30 13:50:39 UTC
Created attachment 209554 [details]
somafm-cli port diff

* Added shebangfix as suggested.
Comment 4 Lewis Cook 2019-11-30 13:51:03 UTC
(In reply to Mateusz Piotrowski from comment #2)
Made the change, cheers.
Comment 5 Mateusz Piotrowski freebsd_committer 2019-12-01 10:35:03 UTC
Thanks!

Let's get this tested.
Comment 6 Mateusz Piotrowski freebsd_committer 2019-12-01 10:37:32 UTC
Nothing important, just for your information: there's a portfmt package that comes with two nice tools: portfmt and portclippy ;) you may want to check those out.

It is unrelated to this PR however.
Comment 7 Lewis Cook 2019-12-01 11:07:24 UTC
(In reply to Mateusz Piotrowski from comment #6)

I've been using portfmt (portlint too) on the Makefiles throughout my submissions, simply running `portfmt -i Makefile` and whatnot. Although I was unaware of portclippy and will absolutely take a look. Many thanks for your time and helpful advice! :)
Comment 8 commit-hook freebsd_committer 2019-12-01 11:07:36 UTC
A commit references this bug:

Author: 0mp
Date: Sun Dec  1 11:07:14 UTC 2019
New revision: 518766
URL: https://svnweb.freebsd.org/changeset/ports/518766

Log:
  New port: audio/somafm-cli

  Stream your favorite music channels from
  somafm.com within a terminal using mpv.

  WWW: https://github.com/rockymadden/somafm-cli

  PR:		242321
  Submitted by:	Lewis Cook <vulcan@wired.sh>

Changes:
  head/audio/Makefile
  head/audio/somafm-cli/
  head/audio/somafm-cli/Makefile
  head/audio/somafm-cli/distinfo
  head/audio/somafm-cli/pkg-descr
Comment 9 Mateusz Piotrowski freebsd_committer 2019-12-01 11:14:32 UTC
Thanks for another high quality patch.

Cheers!
Comment 10 Lewis Cook 2019-12-01 11:16:55 UTC
Have a good one, thanks once again! :)