Bug 242345 - audio/logitechmediaserver : Update to version 8.0.0, 8.1.0
Summary: audio/logitechmediaserver : Update to version 8.0.0, 8.1.0
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2019-12-01 21:46 UTC by Hans Soonieus
Modified: 2020-12-27 11:33 UTC (History)
3 users (show)

See Also:


Attachments
diff between current port and new version (39.89 KB, patch)
2019-12-01 21:46 UTC, Hans Soonieus
no flags Details | Diff
Update logitechmediaserver to 8.0.0 (49.50 KB, patch)
2020-11-30 18:53 UTC, Hans Soonieus
no flags Details | Diff
Update logitechmediaserver to 8.0.0 v2 (49.80 KB, patch)
2020-12-12 13:35 UTC, Hans Soonieus
no flags Details | Diff
Update logitechmediaserver to 8.1.0 (49.87 KB, patch)
2020-12-25 23:24 UTC, Hans Soonieus
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hans Soonieus 2019-12-01 21:46:53 UTC
Created attachment 209578 [details]
diff between current port and new version

This is an update to this port.
2 files have been deleted :
files/custom-convert.conf.in
files/patch-convert.conf

No files have been added.

The port now also builds a modified version of faad. this does not conflict with the audio/faad port and this modified version is only used by logitechmediaserver.
Comment 1 Automation User 2019-12-01 22:04:09 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/99816642
Comment 2 Poul-Henning Kamp freebsd_committer 2020-11-30 17:48:25 UTC
I tried this patch, but it seems to fail on perl5.32 ?

Will try forcing to perl5.30 and report.
Comment 3 Hans Soonieus 2020-11-30 18:53:57 UTC
Created attachment 220112 [details]
Update logitechmediaserver to 8.0.0
Comment 4 Hans Soonieus 2020-11-30 18:58:13 UTC
New patch updates logitechmediaserver to 8.0.0
Tested on i386,amd64,11.4,12.2,Perl-5.30 and Perl-5.32

One file added to port 
files/revision.txt.in

two files deleted
files/custom-convert.conf
files/patch-convert.conf
Comment 5 Poul-Henning Kamp freebsd_committer 2020-11-30 19:57:26 UTC
Tried the 8.0.0 upgrade, works fine, thanks a lot!
Comment 6 daniel.engberg.lists 2020-12-12 06:14:56 UTC
Fails in poudriere (12.2 amd64):

....

====> Running Q/A tests (stage-qa)
Warning: Symlink '/usr/local/share/logitechmediaserver/Cache' pointing to '/var/db/logitechmediaserver/cache' which does not exist in the stage directory or in localbase
Notice: You have some Perl modules as dependencies but you do not have devel/p5-Module-CoreList installed, the perlcore QA check gets better results when using it, especially with older Perl versions.
Warning: License is not auto-accepted, packages will not be built, ports depending on this one will be ignored.
Warning: License does not allow package to be distributed, ports depending on this one will be ignored
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: %%SLIMDIR%%/.editorconfig
Error: Orphaned: %%SLIMDIR%%/.github/workflows/00_smoketest.yaml
Error: Orphaned: %%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/DBD/File/Developers.pod
Error: Orphaned: %%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/DBD/File/HowTo.pod
Error: Orphaned: %%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/DBD/File/Roadmap.pod
Error: Orphaned: %%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/DBD/SQLite/Cookbook.pod
Error: Orphaned: %%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/DBD/SQLite/Fulltext_search.pod
Error: Orphaned: %%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/DBI/DBD/SqlEngine/Developers.pod
Error: Orphaned: %%SLIMDIR%%/CPAN/arch/%%PERL_VER%%/DBI/DBD/SqlEngine/HowTo.pod
Error: Orphaned: %%SLIMDIR%%/t/00_smoketest.sh
===> Checking for items in pkg-plist which are not in STAGEDIR
===> Error: Plist issues found.
*** Error code 1

Stop.
make: stopped in /usr/ports/audio/logitechmediaserver
=>> Error: check-plist failures detected

...

It also seems to bundle quite a few libraries which isn't ideal...
https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/book.html#bundled-libs

Best regards,
Daniel
Comment 7 Hans Soonieus 2020-12-12 13:35:23 UTC
Created attachment 220483 [details]
Update logitechmediaserver to 8.0.0 v2
Comment 8 Hans Soonieus 2020-12-12 13:37:56 UTC
Directory /var/db/logitechmediaserver/cache is created on first run and needs to be preserved during updates

Files missing in pkg-plist were deliberate, they are not needed. New patch now removes them from stagedir.

Any libraries are only used to build specific versions of Perl Modules, no libraries are installed.
Comment 9 Hans Soonieus 2020-12-25 23:24:07 UTC
Created attachment 220924 [details]
Update logitechmediaserver to 8.1.0
Comment 10 Alan Braslau 2020-12-27 05:07:02 UTC
I do not really know what I am doing ... but I succeeded in installing the 8.1.0 patch on freebsd 12.2 amd64.
1) I had to "touch files/revision.txt.in" as this did not exist
2) It used perl5.28 as that is what was installed for the port to compile previously.

I then removed perl5.28 and reinstalled. This pulled in perl5.32 and LMS 8.1.0 is now running fine with perl5.32.

Thank you!
Comment 11 Hans Soonieus 2020-12-27 11:33:33 UTC
I am happy you found this useful Alan.
For other people who are not familiar with patch files ( including me ) here is a way to use them :

1. Download the patch and copy it to your home-directory with the name patchfile ( you can use any name you wish but in the following example I use patchfile )

2. Create a copy of the original port from the ports-tree in your home-directory

cp -r /usr/ports/audio/logitechmediaserver logitechmediaserver

3. Create an empty file revision.txt.in in the correct location

touch logitechmediaserver/files/revision.txt.in

4. Run patch

patch -E -i patchfile -V none

( the -E option removes two files that are empty after the patch and the -V none option means no backup files ( .orig ) are created )

5. You can now install the new version of logitechmediaserver from the direcory ~/logitechmediaserver in the normal way