Bug 242370 - Remove GUI packages as dependencies from emulators/qemu-utils
Summary: Remove GUI packages as dependencies from emulators/qemu-utils
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Muhammad Moinur Rahman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-02 14:59 UTC by Kirill Ponomarev
Modified: 2019-12-07 17:40 UTC (History)
6 users (show)

See Also:
bugzilla: maintainer-feedback? (ken)


Attachments
qemu port patch (1.04 KB, patch)
2019-12-02 15:35 UTC, Andrey Fesenko
no flags Details | Diff
qemu-utils (455 bytes, patch)
2019-12-02 15:38 UTC, Andrey Fesenko
no flags Details | Diff
qemu port patch (1.68 KB, patch)
2019-12-03 11:25 UTC, Andrey Fesenko
no flags Details | Diff
qemu port patch (1.43 KB, patch)
2019-12-03 15:22 UTC, Andrey Fesenko
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kirill Ponomarev freebsd_committer 2019-12-02 14:59:32 UTC
Recent upgrade to qemu port resulted having additional GUI dependencies for emulators/qemu-utils which are superfluous to run on our prod servers.

New packages to be INSTALLED:                                                                                                           
        pango: 1.42.4_3 [poudriere]                                                                                                     
        xorg-fonts-truetype: 7.7_1 [poudriere]                                                                                          
        font-misc-meltho: 1.0.3_4 [poudriere]                                                                                           
        font-misc-ethiopic: 1.0.3_4 [poudriere]                                                                                         
        font-bh-ttf: 1.0.3_4 [poudriere]                                                                                                
        encodings: 1.0.5,1 [poudriere]                                                                                                  
        libXft: 2.3.3 [poudriere]                                                                                                       
        harfbuzz: 2.6.4 [poudriere]                                                                                                     
        graphite2: 1.3.13_1 [poudriere]                                                                                                 
        cairo: 1.16.0,2 [poudriere]                                                                                                     
        pixman: 0.38.4 [poudriere]                                                                                                      
        mesa-libs: 18.3.2_3 [poudriere]                                                                                                 
        libxshmfence: 1.3 [poudriere]
        libXxf86vm: 1.1.4_3 [poudriere]
        libXdamage: 1.1.5 [poudriere]
        wayland: 1.16.0_1 [poudriere]
        libepoll-shim: 0.0.20190311 [poudriere]
        libdrm: 2.4.99,1 [poudriere]
        libpciaccess: 0.16 [poudriere]
        pciids: 20191012 [poudriere]
        libunwind: 20170615 [poudriere]
        fribidi: 0.19.7 [poudriere]
        gtk-update-icon-cache: 2.24.32 [poudriere]
        libXrandr: 1.5.2 [poudriere]
        libXinerama: 1.1.4_2,1 [poudriere]
        libXcursor: 1.2.0 [poudriere]
        libXcomposite: 0.4.5,1 [poudriere]
        shared-mime-info: 1.10_1 [poudriere]
        hicolor-icon-theme: 0.17 [poudriere]
        gdk-pixbuf2: 2.38.1 [poudriere]
        tiff: 4.1.0 [poudriere]
        jpeg-turbo: 2.0.3 [poudriere]
        jbigkit: 2.1_1 [poudriere]
        atk: 2.28.1 [poudriere]
Installed packages to be UPGRADED:
        qemu-utils: 3.1.1.1 -> 4.1.1 [poudriere]

Please remove gtk/gnome dependencies from qemu-utils port.
Comment 1 Andrey Fesenko 2019-12-02 15:35:35 UTC
Created attachment 209610 [details]
qemu port patch

Fast delete gnome dependency for children ports, require testing
Comment 2 Andrey Fesenko 2019-12-02 15:38:09 UTC
Created attachment 209611 [details]
qemu-utils

USE_GNOME glib20 --> libxml2

may be overkill
Comment 3 Andrey Fesenko 2019-12-02 15:47:38 UTC
(In reply to Andrey Fesenko from comment #2)
however, qemu-utils have CONFIGURE_ARGS --disable-gtk, why his depend USE_GNOME?
Comment 4 Andrey Fesenko 2019-12-03 11:25:03 UTC
Created attachment 209646 [details]
qemu port patch

Check patch poudriere 13, 12.1 (i386, amd64)

qemu require glib20 build dependency
Comment 5 Kenneth D. Merry freebsd_committer 2019-12-03 14:22:35 UTC
Thank you for testing this, and for the patch!

The patch looks good to me, assigning this to bofh since the patch is to qemu.
Comment 6 Andrey Fesenko 2019-12-03 15:22:16 UTC
Created attachment 209660 [details]
qemu port patch

Remove LIB_DEPENDS libglib not require, adding this in previous version patch my fault
Comment 7 aborche 2019-12-05 20:48:55 UTC
please checkout a new version of qemu-guest-agent.

https://github.com/aborche/qemu-guest-agent

Maybe possible insert this port to ports tree ?
Comment 8 commit-hook freebsd_committer 2019-12-07 17:34:50 UTC
A commit references this bug:

Author: bofh
Date: Sat Dec  7 17:33:54 UTC 2019
New revision: 519224
URL: https://svnweb.freebsd.org/changeset/ports/519224

Log:
  emulators/qemu: Remove GUI dependencies from emulators/qemu-utils

  PR:		242370
  Submitted by:	krion

Changes:
  head/emulators/qemu/Makefile
Comment 9 Muhammad Moinur Rahman freebsd_committer 2019-12-07 17:39:48 UTC
(In reply to aborche from comment #7)
Let me work on that. Hopefully I will be able to do it within a short notice.